From: Alexandru Ardelean <ardeleanalex@gmail.com>
Date: Thu, 12 Jan 2017 13:31:13 +0000 (+0200)
Subject: tools/cmake: remove HOST_CONFIGURE_CMD and re-distribute the args & vars
X-Git-Url: http://git.cdn.openwrt.org/?a=commitdiff_plain;h=968fa531977f5d5b8ef8da83553f66d4a638cb51;p=openwrt%2Fstaging%2Fldir.git

tools/cmake: remove HOST_CONFIGURE_CMD and re-distribute the args & vars

The final semantic is the same, but this is a bit more correct.

Build tested on Windows 10 (yes, there is some
Ubuntu mode for Windows 10, and I've been also building LEDE
on it for a few weeks).

Signed-off-by: Alexandru Ardelean <ardeleanalex@gmail.com>
---

diff --git a/tools/cmake/Makefile b/tools/cmake/Makefile
index f3712391a6..d6f03e4208 100644
--- a/tools/cmake/Makefile
+++ b/tools/cmake/Makefile
@@ -19,15 +19,12 @@ HOST_CONFIGURE_PARALLEL:=1
 
 include $(INCLUDE_DIR)/host-build.mk
 
-HOST_CONFIGURE_CMD := \
-	MAKEFLAGS="$(HOST_JOBS)" \
-	$(BASH) ./configure \
-		$(if $(MAKE_JOBSERVER),--parallel="$(MAKE_JOBSERVER)")
-
 HOST_CONFIGURE_VARS += \
+	MAKEFLAGS="$(HOST_JOBS)" \
 	CXXFLAGS="$(HOST_CFLAGS)"
 
 HOST_CONFIGURE_ARGS := \
+	$(if $(MAKE_JOBSERVER),--parallel="$(MAKE_JOBSERVER)") \
 	--prefix=$(STAGING_DIR_HOST)
 
 ifneq ($(findstring c,$(OPENWRT_VERBOSE)),)