From: Imre Kaloz <kaloz@openwrt.org>
Date: Mon, 13 Apr 2015 12:06:56 +0000 (+0000)
Subject: mvebu: generate a single firmware for the 385-db-ap
X-Git-Url: http://git.cdn.openwrt.org/?a=commitdiff_plain;h=96c793f529105a80953a586568efbe0142ea7625;p=openwrt%2Fstaging%2Fsvanheule.git

mvebu: generate a single firmware for the 385-db-ap

This has been done without having a board, but should work.

Signed-off-by: Imre Kaloz <kaloz@openwrt.org>

SVN-Revision: 45412
---

diff --git a/target/linux/mvebu/image/Makefile b/target/linux/mvebu/image/Makefile
index 443110113c..191dc27a00 100644
--- a/target/linux/mvebu/image/Makefile
+++ b/target/linux/mvebu/image/Makefile
@@ -154,6 +154,15 @@ define Image/Build/Profile/Mamba/squashfs
 	) > $(BIN_DIR)/$(IMG_PREFIX)-armada-xp-linksys-mamba-squashfs-factory.img
 endef
 
+define Image/Build/Profile/385-DB-AP/squashfs
+	$(call Image/Build/UbinizeImage,armada-385-db-ap,,squashfs, -p 256KiB -m 4096)
+	( \
+		dd if=$(KDIR)/uImage-armada-385-db-ap bs=8M conv=sync; \
+		dd if=$(KDIR)/$(IMG_PREFIX)-armada-385-db-ap-squashfs-ubinized.bin \
+		bs=4096 conv=sync; \
+	) > $(BIN_DIR)/$(IMG_PREFIX)-armada-385-db-ap-squashfs-factory.img
+endef
+
 # The Default profile should build everything
 $(eval $(call MultiProfile,Default,$(PROFILES_LIST)))