From: Florian Fainelli <florian@openwrt.org>
Date: Wed, 7 Oct 2009 13:05:14 +0000 (+0000)
Subject: optimize binaries for the rm5200 cpu present on cobalt, do not use the mips32 isa
X-Git-Tag: reboot~22227
X-Git-Url: http://git.cdn.openwrt.org/?a=commitdiff_plain;h=96d804c54f2968987455be55efaed0940fb87d36;p=openwrt%2Fstaging%2Fblogic.git

optimize binaries for the rm5200 cpu present on cobalt, do not use the mips32 isa

SVN-Revision: 17980
---

diff --git a/target/linux/cobalt/Makefile b/target/linux/cobalt/Makefile
index 0ab1942c5148..10dcf4579418 100644
--- a/target/linux/cobalt/Makefile
+++ b/target/linux/cobalt/Makefile
@@ -10,6 +10,7 @@ ARCH:=mipsel
 BOARD:=cobalt
 BOARDNAME:=Cobalt Microservers
 FEATURES:=tgz pci ext2
+CFLAGS:=-O2 -pipe -mtune=r5000 -funit-at-a-time
 
 LINUX_VERSION:=2.6.30.8
 
diff --git a/toolchain/uClibc/config-0.9.30.1/mipsel.cobalt b/toolchain/uClibc/config-0.9.30.1/mipsel.cobalt
new file mode 100644
index 000000000000..323b0aa52ebe
--- /dev/null
+++ b/toolchain/uClibc/config-0.9.30.1/mipsel.cobalt
@@ -0,0 +1,17 @@
+ARCH_ANY_ENDIAN=y
+ARCH_CFLAGS="-mno-split-addresses"
+ARCH_LITTLE_ENDIAN=y
+ARCH_WANTS_LITTLE_ENDIAN=y
+# CONFIG_MIPS_ISA_1 is not set
+# CONFIG_MIPS_ISA_2 is not set
+CONFIG_MIPS_ISA_3=y
+# CONFIG_MIPS_ISA_4 is not set
+# CONFIG_MIPS_ISA_MIPS32 is not set
+# CONFIG_MIPS_ISA_MIPS32R2 is not set
+# CONFIG_MIPS_ISA_MIPS64 is not set
+# CONFIG_MIPS_N32_ABI is not set
+# CONFIG_MIPS_N64_ABI is not set
+CONFIG_MIPS_O32_ABI=y
+TARGET_ARCH="mips"
+TARGET_mips=y
+UCLIBC_HAS_FPU=y