From: Florian Eckert <fe@dev.tdt.de>
Date: Tue, 2 Jul 2019 10:04:27 +0000 (+0200)
Subject: kernel: add gpio-amd-fch module description
X-Git-Url: http://git.cdn.openwrt.org/?a=commitdiff_plain;h=97bc87d81a98dc0597b6492017cef9098cc9c012;p=openwrt%2Fstaging%2Fldir.git

kernel: add gpio-amd-fch module description

Add a module description for the new gpio-amd-fch device driver.

Signed-off-by: Florian Eckert <fe@dev.tdt.de>
---

diff --git a/package/kernel/linux/modules/other.mk b/package/kernel/linux/modules/other.mk
index 936a1327fd..15d67b4679 100644
--- a/package/kernel/linux/modules/other.mk
+++ b/package/kernel/linux/modules/other.mk
@@ -313,6 +313,23 @@ endef
 $(eval $(call KernelPackage,gpio-it87))
 
 
+define KernelPackage/gpio-amd-fch
+  SUBMENU:=$(OTHER_MENU)
+  DEPENDS:=@GPIO_SUPPORT @TARGET_x86
+  TITLE:=GPIO support for AMD Fusion Controller Hub (G-series SOCs)
+  KCONFIG:=CONFIG_GPIO_AMD_FCH
+  FILES:=$(LINUX_DIR)/drivers/gpio/gpio-amd-fch.ko
+  AUTOLOAD:=$(call AutoLoad,25,gpio-amd-fch,1)
+endef
+
+define KernelPackage/gpio-amd-fch/description
+  This option enables driver for GPIO on AMDs Fusion Controller Hub,
+  as found on G-series SOCs (eg. GX-412TC)
+endef
+
+$(eval $(call KernelPackage,gpio-amd-fch))
+
+
 define KernelPackage/ppdev
   SUBMENU:=$(OTHER_MENU)
   TITLE:=Parallel port support