From: Mathias Kresin <dev@kresin.me>
Date: Fri, 14 Jul 2017 17:35:02 +0000 (+0200)
Subject: image: fix ar71xx legacy images
X-Git-Url: http://git.cdn.openwrt.org/?a=commitdiff_plain;h=9fe9175c2f674607f8e26214b45382591c27f54a;p=openwrt%2Fstaging%2F981213.git

image: fix ar71xx legacy images

If TARGET_PER_DEVICE_ROOTFS and DEVICE_PACKAGES are used for ar71xx
legacy images:

- an already jffs2 padded squashfs rootfs is overwritten
  with an unpadded/raw one.

- the squashfs-raw and squashfs-64k rootfs are not replaced by the
  ones including the DEVICE_PACKAGES

Call Image/Build/squashfs after the DEVICE_PACKAGES are added to the
base squashfs rootfs to fix the issues.

Fixes: FS#904

Signed-off-by: Mathias Kresin <dev@kresin.me>
---

diff --git a/include/image-legacy.mk b/include/image-legacy.mk
index 1864d714e5..1ccaec09b0 100644
--- a/include/image-legacy.mk
+++ b/include/image-legacy.mk
@@ -48,6 +48,7 @@ endef
 ifdef TARGET_PER_DEVICE_ROOTFS
   define Image/Build/Profile/Filesystem
 	cp $(KDIR)/root.$(2)+pkg=$(3) $(KDIR)/root.$(2)
+	$(call Image/Build/$(2),$(2))
 	$(call Image/Build/Profile,$(1),$(2))
   endef
 else