From: Jo-Philipp Wich <jow@openwrt.org>
Date: Wed, 28 Oct 2009 00:11:59 +0000 (+0000)
Subject: lua: the variable expansion to detect the host os does not work with GNU Make 3.81... 
X-Git-Tag: reboot~22041
X-Git-Url: http://git.cdn.openwrt.org/?a=commitdiff_plain;h=a0d2c6503307b70774730bfd8b9e7e773b112b8a;p=openwrt%2Fstaging%2Fxback.git

lua: the variable expansion to detect the host os does not work with GNU Make 3.81, replace it with a nested ifeq

SVN-Revision: 18193
---

diff --git a/package/lua/Makefile b/package/lua/Makefile
index 9d9c77b9e4..c8c64badf4 100644
--- a/package/lua/Makefile
+++ b/package/lua/Makefile
@@ -115,10 +115,15 @@ define Host/Configure
 	$(SED) 's,"/usr/local/","$(STAGING_DIR_HOST)/",' $(HOST_BUILD_DIR)/src/luaconf.h
 endef
 
-LUA_OS.Darwin:=macosx
-LUA_OS.FreeBSD:=freebsd
-LUA_OS:=$(LUA_OS.$(HOST_OS))
-LUA_OS?=linux
+ifeq ($(HOST_OS),Darwin)
+	LUA_OS:=macosx
+else
+	ifeq ($(HOST_OS),FreeBSD)
+		LUA_OS:=freebsd
+	else
+		LUA_OS:=linux
+	endif
+endif
 
 define Host/Compile
 	$(MAKE) -C $(HOST_BUILD_DIR) \