From: Mike Baker <mbm@openwrt.org>
Date: Fri, 19 May 2006 23:02:14 +0000 (+0000)
Subject: fix .pkginfo line to allow the use of $(SOURCE)
X-Git-Url: http://git.cdn.openwrt.org/?a=commitdiff_plain;h=a3281a2f3bd6604d02d6543bce188c9adea82708;p=openwrt%2Fstaging%2Fthess.git

fix .pkginfo line to allow the use of $(SOURCE)

SVN-Revision: 3802
---

diff --git a/openwrt/Makefile b/openwrt/Makefile
index 9b9d1c955e..9b341f1241 100644
--- a/openwrt/Makefile
+++ b/openwrt/Makefile
@@ -41,11 +41,11 @@ export OPENWRTVERSION
 all:
 
 .pkginfo: FORCE
-ifeq ($(shell ./scripts/timestamp.pl -p .pkginfo package),package)
+ifneq ($(shell ./scripts/timestamp.pl -p .pkginfo package Makefile),.pkginfo)
 	@echo Collecting package info...
-	@-for makefile in package/*/Makefile; do \
-		echo Source-Makefile: $$makefile; \
-		$(MAKE) --no-print-dir DUMP=1 -f $$makefile 2>&- || true; \
+	@-for dir in package/*/; do \
+		echo Source-Makefile: $${dir}Makefile; \
+		$(MAKE) --no-print-dir DUMP=1 -C $$dir 2>&- || true; \
 	done > $@
 endif
 
diff --git a/openwrt/package/busybox/Makefile b/openwrt/package/busybox/Makefile
index ff23ee7dd8..cc36301f52 100644
--- a/openwrt/package/busybox/Makefile
+++ b/openwrt/package/busybox/Makefile
@@ -23,10 +23,11 @@ TITLE:=Core utilities for embedded Linux
 DESCRIPTION:=The Swiss Army Knife of embedded Linux. \\\
 It slices, it dices, it makes Julian Fries.
 URL:=http://busybox.net/
-CONFIG:=menu "Configuration" \\\
-	depends on PACKAGE_busybox \\\
-source "package/busybox/config/Config.in" \\\
-endmenu
+CONFIG:=\\\
+	menu "Configuration" \\\
+		depends on PACKAGE_busybox \\\
+		source "$(SOURCE)/config/Config.in" \\\
+	endmenu
 endef
 
 define Build/Configure