From: John Crispin <john@phrozen.org>
Date: Wed, 15 Jan 2020 20:31:12 +0000 (+0100)
Subject: dropbear: fix compile error
X-Git-Url: http://git.cdn.openwrt.org/?a=commitdiff_plain;h=a3dd95ef63c7824da6341f97d48f90f30a01e879;p=openwrt%2Fstaging%2Fblogic.git

dropbear: fix compile error

Fixes: 0da193ee6943 ("dropbear: move failsafe code out of base-files")
Signed-off-by: John Crispin <john@phrozen.org>
---

diff --git a/package/network/services/dropbear/Makefile b/package/network/services/dropbear/Makefile
index 8b5bc17c9de3..59b4f5495449 100644
--- a/package/network/services/dropbear/Makefile
+++ b/package/network/services/dropbear/Makefile
@@ -158,7 +158,8 @@ define Package/dropbear/install
 	$(INSTALL_BIN) ./files/dropbear.init $(1)/etc/init.d/dropbear
 	$(INSTALL_DIR) $(1)/usr/lib/opkg/info
 	$(INSTALL_DIR) $(1)/etc/dropbear
-	$(INSTALL_DIR) ./files/dropbear.failsafe $(1)/lib/preinit/99_10_failsafe_dropbear
+	$(INSTALL_DIR) $(1)/lib/preinit
+	$(INSTALL_DATA) ./files/dropbear.failsafe $(1)/lib/preinit/99_10_failsafe_dropbear
 	$(if $(CONFIG_DROPBEAR_ECC),touch $(1)/etc/dropbear/dropbear_ecdsa_host_key)
 	touch $(1)/etc/dropbear/dropbear_rsa_host_key
 endef