From: Felix Fietkau <nbd@openwrt.org>
Date: Sun, 17 Mar 2013 21:12:02 +0000 (+0000)
Subject: build: make the color of the 'configuration out of sync' warning red to make it harde... 
X-Git-Url: http://git.cdn.openwrt.org/?a=commitdiff_plain;h=a4c8d4e3779af3169825c48b6de782a3620304f7;p=openwrt%2Fstaging%2Fzorun.git

build: make the color of the 'configuration out of sync' warning red to make it harder for users to overlook

SVN-Revision: 36082
---

diff --git a/include/toplevel.mk b/include/toplevel.mk
index 0918298b16..5e8e6dd1ba 100644
--- a/include/toplevel.mk
+++ b/include/toplevel.mk
@@ -9,6 +9,8 @@
 RELEASE:=Barrier Breaker
 PREP_MK= OPENWRT_BUILD= QUIET=0
 
+export IS_TTY=$(shell tty -s && echo 1 || echo 0)
+
 include $(TOPDIR)/include/verbose.mk
 
 ifeq ($(SDK),1)
@@ -22,7 +24,6 @@ OPENWRTVERSION:=$(RELEASE)$(if $(REVISION), ($(REVISION)))
 export RELEASE
 export REVISION
 export OPENWRTVERSION
-export IS_TTY=$(shell tty -s && echo 1 || echo 0)
 export LD_LIBRARY_PATH:=$(subst ::,:,$(if $(LD_LIBRARY_PATH),$(LD_LIBRARY_PATH):)$(STAGING_DIR_HOST)/lib)
 export DYLD_LIBRARY_PATH:=$(subst ::,:,$(if $(DYLD_LIBRARY_PATH),$(DYLD_LIBRARY_PATH):)$(STAGING_DIR_HOST)/lib)
 export GIT_CONFIG_PARAMETERS='core.autocrlf=false'
@@ -148,7 +149,7 @@ prereq:: prepare-tmpinfo .config
 		cp .config tmp/.config; \
 		./scripts/config/conf -D tmp/.config -w tmp/.config Config.in > /dev/null 2>&1; \
 		if ./scripts/kconfig.pl '>' .config tmp/.config | grep -q CONFIG; then \
-			echo "WARNING: your configuration is out of sync. Please run make menuconfig, oldconfig or defconfig!" >&2; \
+			printf "$(_R)WARNING: your configuration is out of sync. Please run make menuconfig, oldconfig or defconfig!$(_N)\n" >&2; \
 		fi \
 	)
 	@+$(ULIMIT_FIX) $(SUBMAKE) -r $@
diff --git a/include/verbose.mk b/include/verbose.mk
index 2e8ace442e..d34f55fc48 100644
--- a/include/verbose.mk
+++ b/include/verbose.mk
@@ -27,6 +27,7 @@ endif
 ifeq ($(IS_TTY),1)
   ifneq ($(strip $(NO_COLOR)),1)
     _Y:=\\033[33m
+    _R:=\\033[31m
     _N:=\\033[m
   endif
 endif
@@ -36,6 +37,10 @@ ifeq ($(findstring s,$(OPENWRT_VERBOSE)),)
 	printf "$(_Y)%s$(_N)\n" "$(1)" >&8
   endef
 
+  define ERROR_MESSAGE
+	printf "$(_R)%s$(_N)\n" "$(1)" >&8
+  endef
+
   ifeq ($(QUIET),1)
     ifneq ($(CURDIR),$(TOPDIR))
       _DIR:=$(patsubst $(TOPDIR)/%,%,${CURDIR})
@@ -58,4 +63,5 @@ else
   define MESSAGE
     printf "%s\n" "$(1)"
   endef
+  ERROR_MESSAGE=$(MESSAGE)
 endif