From: Adoal Xu <adoalxu@gmail.com>
Date: Sun, 3 Jun 2018 17:04:51 +0000 (+0800)
Subject: ath79: add TP-Link TL-MR10U port
X-Git-Url: http://git.cdn.openwrt.org/?a=commitdiff_plain;h=a51078f7354fac9e31f6956cbddc77aaef02c67b;p=openwrt%2Fstaging%2Fnbd.git

ath79: add TP-Link TL-MR10U port

Signed-off-by: Adoal Xu <adoalxu@gmail.com>
---

diff --git a/target/linux/ath79/base-files/etc/board.d/02_network b/target/linux/ath79/base-files/etc/board.d/02_network
index e6ef47240f..c02d9ff063 100755
--- a/target/linux/ath79/base-files/etc/board.d/02_network
+++ b/target/linux/ath79/base-files/etc/board.d/02_network
@@ -9,6 +9,7 @@ ath79_setup_interfaces()
 
 	case "$board" in
 	"avm,fritz300e"|\
+	"tplink,tl-mr10u"|\
 	"tplink,tl-wr703n"|\
 	"ubnt,unifi")
 		ucidef_set_interface_lan "eth0"
diff --git a/target/linux/ath79/dts/ar9331_tl-mr10u.dts b/target/linux/ath79/dts/ar9331_tl-mr10u.dts
new file mode 100644
index 0000000000..9a6947c951
--- /dev/null
+++ b/target/linux/ath79/dts/ar9331_tl-mr10u.dts
@@ -0,0 +1,19 @@
+// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
+/dts-v1/;
+
+#include "ar9331_tl-wr703n.dtsi"
+
+/ {
+	model = "TP-Link MR10U";
+	compatible = "tplink,tl-mr10u";
+
+	reg_usb_vbus: reg_usb_vbus {
+		compatible = "regulator-fixed";
+		regulator-name = "usb_vbus";
+		regulator-min-microvolt = <5000000>;
+		regulator-max-microvolt = <5000000>;
+		gpio = <&gpio 28 GPIO_ACTIVE_HIGH>;
+		enable-active-high;
+	};
+
+};
diff --git a/target/linux/ath79/dts/ar9331_tl-wr703n.dts b/target/linux/ath79/dts/ar9331_tl-wr703n.dts
index 70f94ed4cb..17747052e6 100644
--- a/target/linux/ath79/dts/ar9331_tl-wr703n.dts
+++ b/target/linux/ath79/dts/ar9331_tl-wr703n.dts
@@ -1,139 +1,9 @@
 // SPDX-License-Identifier: GPL-2.0-or-later OR MIT
 /dts-v1/;
 
-#include <dt-bindings/gpio/gpio.h>
-#include <dt-bindings/input/input.h>
-
-#include "ar9331.dtsi"
+#include "ar9331_tl-wr703n.dtsi"
 
 / {
-	compatible = "tplink,tl-wr703n", "qca,ar9331";
-	model = "TP-Link TL-WR703N";
-
-	aliases {
-		serial0 = &uart;
-		led-status = &led_system;
-	};
-
-	memory@0 {
-		device_type = "memory";
-		reg = <0x0 0x2000000>;
-	};
-
-	gpio-keys-polled {
-		compatible = "gpio-keys-polled";
-		#address-cells = <1>;
-		#size-cells = <0>;
-		poll-interval = <20>;
-
-		reset {
-			label = "reset";
-			linux,code = <KEY_RESTART>;
-			gpios = <&gpio 11 GPIO_ACTIVE_LOW>;
-			debounce-interval = <60>;
-		};
-	};
-	
-	gpio-leds {
-		compatible = "gpio-leds";
-
-		led_system: system {
-			label = "tl-wr703n:blue:system";
-			gpios = <&gpio 27 GPIO_ACTIVE_LOW>;
-		};
-	};
-
-	reg_usb_vbus: reg_usb_vbus {
-		compatible = "regulator-fixed";
-		regulator-name = "usb_vbus";
-		regulator-min-microvolt = <5000000>;
-		regulator-max-microvolt = <5000000>;
-		gpio = <&gpio 8 GPIO_ACTIVE_HIGH>;
-		enable-active-high;
-	};
-
-};
-
-&spi {
-	status = "okay";
-	num-cs = <1>;
-
-	flash@0 {
-		#address-cells = <1>;
-		#size-cells = <1>;
-		compatible = "jedec,spi-nor";
-		reg = <0>;
-		spi-max-frequency = <25000000>;
-
-		partitions {
-			compatible = "fixed-partitions";
-			#address-cells = <1>;
-			#size-cells = <1>;
-
-			uboot: partition@0 {
-				reg = <0x0 0x20000>;
-				label = "u-boot";
-				read-only;
-			};
-
-			firmware: partition@20000 {
-				reg = <0x20000 0x3d0000>;
-				label = "firmware";
-			};
-
-			art: partition@3f0000 {
-				reg = <0x3f0000 0x10000>;
-				label = "art";
-				read-only;
-			};
-		};
-	};
-};
-
-&eth0 {
-	status = "okay";
-
-	phy-handle = <&phy4>;
-
-	mtd-mac-address = <&uboot 0x1fc00>;
-
-	gmac-config {
-		device = <&gmac>;
-
-		switch-phy-addr-swap = <0>;
-		switch-phy-swap = <0>;
-	};
-};
-
-&gpio {
-	status = "okay";
-};
-
-&mdio0 {
-	status = "okay";
-
-	phy4: ethernet-phy@4 {
-		reg = <4>;
-		phy-mode = "mii";
-	};
-};
-
-&uart {
-	status = "okay";
-};
-
-&usb {
-	dr_mode = "host";
-	vbus-supply = <&reg_usb_vbus>;
-	status = "okay";
-};
-
-&usb_phy {
-	status = "okay";
-};
-
-&wmac {
-	status = "okay";
-	mtd-cal-data = <&art 0x1000>;
-	mtd-mac-address = <&uboot 0x1fc00>;
+	model = "TP-Link WR703N";
+	compatible = "tplink,tl-wr703n";
 };
diff --git a/target/linux/ath79/dts/ar9331_tl-wr703n.dtsi b/target/linux/ath79/dts/ar9331_tl-wr703n.dtsi
new file mode 100644
index 0000000000..70f94ed4cb
--- /dev/null
+++ b/target/linux/ath79/dts/ar9331_tl-wr703n.dtsi
@@ -0,0 +1,139 @@
+// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
+/dts-v1/;
+
+#include <dt-bindings/gpio/gpio.h>
+#include <dt-bindings/input/input.h>
+
+#include "ar9331.dtsi"
+
+/ {
+	compatible = "tplink,tl-wr703n", "qca,ar9331";
+	model = "TP-Link TL-WR703N";
+
+	aliases {
+		serial0 = &uart;
+		led-status = &led_system;
+	};
+
+	memory@0 {
+		device_type = "memory";
+		reg = <0x0 0x2000000>;
+	};
+
+	gpio-keys-polled {
+		compatible = "gpio-keys-polled";
+		#address-cells = <1>;
+		#size-cells = <0>;
+		poll-interval = <20>;
+
+		reset {
+			label = "reset";
+			linux,code = <KEY_RESTART>;
+			gpios = <&gpio 11 GPIO_ACTIVE_LOW>;
+			debounce-interval = <60>;
+		};
+	};
+	
+	gpio-leds {
+		compatible = "gpio-leds";
+
+		led_system: system {
+			label = "tl-wr703n:blue:system";
+			gpios = <&gpio 27 GPIO_ACTIVE_LOW>;
+		};
+	};
+
+	reg_usb_vbus: reg_usb_vbus {
+		compatible = "regulator-fixed";
+		regulator-name = "usb_vbus";
+		regulator-min-microvolt = <5000000>;
+		regulator-max-microvolt = <5000000>;
+		gpio = <&gpio 8 GPIO_ACTIVE_HIGH>;
+		enable-active-high;
+	};
+
+};
+
+&spi {
+	status = "okay";
+	num-cs = <1>;
+
+	flash@0 {
+		#address-cells = <1>;
+		#size-cells = <1>;
+		compatible = "jedec,spi-nor";
+		reg = <0>;
+		spi-max-frequency = <25000000>;
+
+		partitions {
+			compatible = "fixed-partitions";
+			#address-cells = <1>;
+			#size-cells = <1>;
+
+			uboot: partition@0 {
+				reg = <0x0 0x20000>;
+				label = "u-boot";
+				read-only;
+			};
+
+			firmware: partition@20000 {
+				reg = <0x20000 0x3d0000>;
+				label = "firmware";
+			};
+
+			art: partition@3f0000 {
+				reg = <0x3f0000 0x10000>;
+				label = "art";
+				read-only;
+			};
+		};
+	};
+};
+
+&eth0 {
+	status = "okay";
+
+	phy-handle = <&phy4>;
+
+	mtd-mac-address = <&uboot 0x1fc00>;
+
+	gmac-config {
+		device = <&gmac>;
+
+		switch-phy-addr-swap = <0>;
+		switch-phy-swap = <0>;
+	};
+};
+
+&gpio {
+	status = "okay";
+};
+
+&mdio0 {
+	status = "okay";
+
+	phy4: ethernet-phy@4 {
+		reg = <4>;
+		phy-mode = "mii";
+	};
+};
+
+&uart {
+	status = "okay";
+};
+
+&usb {
+	dr_mode = "host";
+	vbus-supply = <&reg_usb_vbus>;
+	status = "okay";
+};
+
+&usb_phy {
+	status = "okay";
+};
+
+&wmac {
+	status = "okay";
+	mtd-cal-data = <&art 0x1000>;
+	mtd-mac-address = <&uboot 0x1fc00>;
+};
diff --git a/target/linux/ath79/image/tiny-tp-link.mk b/target/linux/ath79/image/tiny-tp-link.mk
index e6d5feefc5..f92c7d9644 100644
--- a/target/linux/ath79/image/tiny-tp-link.mk
+++ b/target/linux/ath79/image/tiny-tp-link.mk
@@ -1,6 +1,16 @@
 include ./common-tp-link.mk
 
 
+define Device/tl-mr10u
+  $(Device/tplink-4mlzma)
+  ATH_SOC := ar9331
+  DEVICE_TITLE := TP-Link TL-MR10U
+  DEVICE_PACKAGES := kmod-usb-chipidea2
+  TPLINK_HWID := 0x00100101
+  SUPPORTED_DEVICES := tplink,tl-mr10u tl-mr10u
+endef
+TARGET_DEVICES += tl-mr10u
+
 define Device/tl-wr703n
   $(Device/tplink-4mlzma)
   ATH_SOC := ar9331