From: John Crispin <john@phrozen.org>
Date: Wed, 9 May 2018 17:55:10 +0000 (+0200)
Subject: kernel: fix chipidea2 dependencies
X-Git-Url: http://git.cdn.openwrt.org/?a=commitdiff_plain;h=a564cfcd8353f57950f8bf5861691202b1aee782;p=openwrt%2Fstaging%2Fldir.git

kernel: fix chipidea2 dependencies

Signed-off-by: John Crispin <john@phrozen.org>
---

diff --git a/package/kernel/linux/modules/usb.mk b/package/kernel/linux/modules/usb.mk
index 7c41e18fd9..0c5bb33f38 100644
--- a/package/kernel/linux/modules/usb.mk
+++ b/package/kernel/linux/modules/usb.mk
@@ -1536,7 +1536,7 @@ $(eval $(call KernelPackage,usb-chipidea))
 
 define KernelPackage/usb-chipidea2
   TITLE:=Host and device support for Chipidea2 controllers
-  DEPENDS:=+USB_GADGET_SUPPORT:kmod-usb-gadget @TARGET_ar71xx||TARGET_ath79 +kmod-usb-ehci +kmod-usb-phy-nop
+  DEPENDS:=+kmod-usb-chipidea
   KCONFIG:= \
 	CONFIG_EXTCON \
 	CONFIG_USB_CHIPIDEA \