From: Jo-Philipp Wich <jow@openwrt.org>
Date: Thu, 18 Jul 2013 13:57:40 +0000 (+0000)
Subject: linux: add missing dependency to kmod-i2c-tiny-usb
X-Git-Tag: reboot~9833
X-Git-Url: http://git.cdn.openwrt.org/?a=commitdiff_plain;h=a5f93fad9d8f76deedf6eb0ffb62d574ebe68b59;p=openwrt%2Fstaging%2Fpepe2k.git

linux: add missing dependency to kmod-i2c-tiny-usb

SVN-Revision: 37399
---

diff --git a/package/kernel/linux/modules/i2c.mk b/package/kernel/linux/modules/i2c.mk
index 077296541a..7af5f5f4a1 100644
--- a/package/kernel/linux/modules/i2c.mk
+++ b/package/kernel/linux/modules/i2c.mk
@@ -158,7 +158,7 @@ I2C_TINY_USB_MODULES:= \
 define KernelPackage/i2c-tiny-usb
   $(call i2c_defaults,$(I2C_TINY_USB_MODULES),59)
   TITLE:=I2C Tiny USB adaptor
-  DEPENDS:=@USB_SUPPORT kmod-i2c-core
+  DEPENDS:=@USB_SUPPORT kmod-i2c-core +kmod-usb-core
 endef
 
 define KernelPackage/i2c-tiny-usb/description