From: Nicolas Thill <nico@openwrt.org>
Date: Fri, 30 Apr 2010 18:43:39 +0000 (+0000)
Subject: target/x86: add to changes missed from [21246] preventing .vdi & .vmdk image generation
X-Git-Tag: reboot~19991
X-Git-Url: http://git.cdn.openwrt.org/?a=commitdiff_plain;h=a64f53f482b3fba4d5ed536a8b53934b97097cf9;p=openwrt%2Fstaging%2Fchunkeey.git

target/x86: add to changes missed from [21246] preventing .vdi & .vmdk image generation

SVN-Revision: 21277
---

diff --git a/target/linux/x86/image/Makefile b/target/linux/x86/image/Makefile
index 1c94634f2c..912dae235f 100644
--- a/target/linux/x86/image/Makefile
+++ b/target/linux/x86/image/Makefile
@@ -152,7 +152,7 @@ ifneq ($(CONFIG_X86_VDI_IMAGES),)
   define Image/Build/vdi
     # left here because the image builder doesnt need these
     ifeq ($(1),ext2)
-		rm $(BIN_DIR)/$(IMG_PREFIX)-ext2.vdi || true
+		rm $(BIN_DIR)/$(IMG_PREFIX)-combined-$(1).vdi || true
 		VBoxManage convertfromraw -format VDI \
 			$(BIN_DIR)/$(IMG_PREFIX)-combined-$(1).img \
 			$(BIN_DIR)/$(IMG_PREFIX)-combined-$(1).vdi
@@ -166,7 +166,7 @@ ifneq ($(CONFIG_X86_VMDK_IMAGES),)
   define Image/Build/vmdk
     # left here because the image builder doesnt need these
     ifeq ($(1),ext2)
-		rm $(BIN_DIR)/$(IMG_PREFIX)-ext2.vmdk || true
+		rm $(BIN_DIR)/$(IMG_PREFIX)-combined-$(1).vmdk || true
 		qemu-img convert -f raw -O vmdk \
 			$(BIN_DIR)/$(IMG_PREFIX)-combined-$(1).img \
 			$(BIN_DIR)/$(IMG_PREFIX)-combined-$(1).vmdk