From: John Crispin <john@openwrt.org>
Date: Mon, 17 Aug 2015 06:04:39 +0000 (+0000)
Subject: brcm2708: fix kmod-sound-soc-iqaudio-dac and add missing symbol
X-Git-Url: http://git.cdn.openwrt.org/?a=commitdiff_plain;h=a6e47b832473da9ed051191b986043ee9fc41eb2;p=openwrt%2Fstaging%2Fansuel.git

brcm2708: fix kmod-sound-soc-iqaudio-dac and add missing symbol

Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com>

SVN-Revision: 46641
---

diff --git a/target/linux/brcm2708/modules.mk b/target/linux/brcm2708/modules.mk
index 5c87c154cb..03aa19b91e 100644
--- a/target/linux/brcm2708/modules.mk
+++ b/target/linux/brcm2708/modules.mk
@@ -168,7 +168,7 @@ define KernelPackage/sound-soc-iqaudio-dac
 	$(LINUX_DIR)/sound/soc/bcm/snd-soc-iqaudio-dac.ko \
 	$(LINUX_DIR)/sound/soc/codecs/snd-soc-pcm512x.ko \
 	$(LINUX_DIR)/sound/soc/codecs/snd-soc-pcm512x-i2c.ko
-  AUTOLOAD:=$(call AutoLoad,68,sound-soc-bcm2708-i2s snd-soc-pcm512x-i2c snd-soc-iqaudio-dac)
+  AUTOLOAD:=$(call AutoLoad,68,snd-soc-pcm512x snd-soc-pcm512x-i2c snd-soc-iqaudio-dac)
   DEPENDS:=kmod-sound-soc-bcm2708-i2s
   $(call AddDepends/sound)
 endef
@@ -271,7 +271,9 @@ I2C_BCM2708_MODULES:=\
 define KernelPackage/i2c-bcm2708
   $(call i2c_defaults,$(I2C_BCM2708_MODULES),59)
   TITLE:=Broadcom BCM2708 I2C master controller driver
-  KCONFIG+= CONFIG_I2C_BCM2708_BAUDRATE=100000
+  KCONFIG+= \
+	CONFIG_I2C_BCM2708_BAUDRATE=100000 \
+	CONFIG_MFD_RPISENSE_CORE=n
   DEPENDS:=@TARGET_brcm2708 +kmod-i2c-core
 endef
 
@@ -287,6 +289,8 @@ I2C_BCM2835_MODULES:=\
 define KernelPackage/i2c-bcm2835
   $(call i2c_defaults,$(I2C_BCM2835_MODULES),59)
   TITLE:=Broadcom BCM2835 I2C master controller driver
+  KCONFIG+= \
+	CONFIG_MFD_RPISENSE_CORE=n
   DEPENDS:=@TARGET_brcm2708 +kmod-i2c-core
 endef