From: Imre Kaloz <kaloz@openwrt.org>
Date: Wed, 14 Jan 2015 11:39:20 +0000 (+0000)
Subject: mvebu: Switch to the generic mkuimage macro
X-Git-Url: http://git.cdn.openwrt.org/?a=commitdiff_plain;h=a72bf9f3d262f4e7f8254c2f774a280c80af3181;p=openwrt%2Fstaging%2Fwigyori.git

mvebu: Switch to the generic mkuimage macro

The mvebu image makefile define something almost identical to the generic
implementation found in include/image.mk.

Switch to this implementation.

Signed-off-by: Maxime Ripard <maxime.ripard@free-electrons.com>

SVN-Revision: 43969
---

diff --git a/target/linux/mvebu/image/Makefile b/target/linux/mvebu/image/Makefile
index f265dc43d2..6e00346fe2 100644
--- a/target/linux/mvebu/image/Makefile
+++ b/target/linux/mvebu/image/Makefile
@@ -24,15 +24,12 @@ KDIR_TMP:=$(KDIR)/tmp
 
 UIMAGE:=$(BIN_DIR)/$(IMG_PREFIX)-uImage
 
-define Image/Build/MkuImage
-	mkimage -A arm -O linux -T kernel -a $(LOADADDR) -C none -e $(LOADADDR) \
-	-n 'ARM OpenWrt Linux-$(LINUX_VERSION)' -d $(1) $(2);
-endef
-
 define Image/Build/DTB
 	cp $(KDIR)/zImage$(2) $(KDIR)/zImage$(2)-$(1);
 	cat $(DTS_DIR)/$(1).dtb >> $(KDIR)/zImage$(2)-$(1);
-	$(call Image/Build/MkuImage,$(KDIR)/zImage$(2)-$(1),$(KDIR)/uImage$(2)-$(1))
+	$(call Image/BuildKernel/MkuImage, \
+		none, $(LOADADDR), $(LOADADDR), \
+		$(KDIR)/zImage$(2)-$(1), $(KDIR)/uImage$(2)-$(1))
 	cp $(KDIR)/uImage$(2)-$(1) $(UIMAGE)$(2)-$(1);
 endef