From: Tomasz Maciej Nowak <tomek_n@o2.pl>
Date: Sat, 17 Dec 2016 20:30:42 +0000 (+0100)
Subject: kernel: don't load pcmcia_rsrc in kmod-pcmcia-yenta
X-Git-Url: http://git.cdn.openwrt.org/?a=commitdiff_plain;h=a7cacc97357460a51d83abf589a80f6ab1a4d95a;p=openwrt%2Fstaging%2Fldir.git

kernel: don't load pcmcia_rsrc in kmod-pcmcia-yenta

Kmod-pcmcia-yenta already depends on kmod-pcmcia-rsrc so there is no
need to load it second time.

Signen-off-by: Tomasz Maciej Nowak <tomek_n@o2.pl>
---

diff --git a/package/kernel/linux/modules/pcmcia.mk b/package/kernel/linux/modules/pcmcia.mk
index 51668facf0..52c115be9d 100644
--- a/package/kernel/linux/modules/pcmcia.mk
+++ b/package/kernel/linux/modules/pcmcia.mk
@@ -50,7 +50,7 @@ define KernelPackage/pcmcia-yenta
   DEPENDS:=kmod-pcmcia-rsrc
   KCONFIG:=CONFIG_YENTA
   FILES:=$(LINUX_DIR)/drivers/pcmcia/yenta_socket.ko
-  AUTOLOAD:=$(call AutoLoad,41,pcmcia_rsrc yenta_socket)
+  AUTOLOAD:=$(call AutoLoad,41,yenta_socket)
 endef
 
 $(eval $(call KernelPackage,pcmcia-yenta))