From: Jo-Philipp Wich <jo@mein.io>
Date: Tue, 10 Jan 2017 14:12:21 +0000 (+0100)
Subject: build: scan.mk: remove overlay broad grep pattern
X-Git-Url: http://git.cdn.openwrt.org/?a=commitdiff_plain;h=a891e5e14f34d79005de0606eebf32b292f86023;p=openwrt%2Fstaging%2Fldir.git

build: scan.mk: remove overlay broad grep pattern

Commit af0b91c "allow scan.mk to find python packages introduced in [8639]"
added some special casing to scan.mk to accomodate some nonstandard python
packages.

Nowadays this pattern is not needed anymore and produces false positives
when using the LEDE source repository as feed within the SDK since the
metadata scanning wrongly picks up target/imagebuilder/Makefile as package,
leading to an  "ERROR: please fix feeds/base/target/imagebuilder/Makefile"
message.

Remove the now uneeded pattern to fix such stray errors during metadata
scanning.

Signed-off-by: Jo-Philipp Wich <jo@mein.io>
---

diff --git a/include/scan.mk b/include/scan.mk
index 5b1f53bdca..9b361f8b3b 100644
--- a/include/scan.mk
+++ b/include/scan.mk
@@ -51,7 +51,7 @@ $(OVERRIDELIST):
 ifeq ($(SCAN_NAME),target)
   GREP_STRING=BuildTarget
 else
-  GREP_STRING=(Build/DefaultTargets|BuildPackage|.+Package)
+  GREP_STRING=(Build/DefaultTargets|BuildPackage)
 endif
 
 $(FILELIST): $(OVERRIDELIST)