From: Felix Fietkau <nbd@nbd.name>
Date: Sat, 14 Nov 2020 11:47:39 +0000 (+0100)
Subject: tools/libelf: use autoreconf to fix build failure on macOS with recent Xcode versions
X-Git-Url: http://git.cdn.openwrt.org/?a=commitdiff_plain;h=a99f88a1866ec082ab635db31a90de618840b165;p=openwrt%2Fstaging%2Fdedeckeh.git

tools/libelf: use autoreconf to fix build failure on macOS with recent Xcode versions

Signed-off-by: Felix Fietkau <nbd@nbd.name>
---

diff --git a/tools/libelf/Makefile b/tools/libelf/Makefile
index 9fec8308b5..726c4776bf 100644
--- a/tools/libelf/Makefile
+++ b/tools/libelf/Makefile
@@ -18,8 +18,12 @@ PKG_SOURCE_URL:= \
 	http://distcache.freebsd.org/ports-distfiles/
 HOST_BUILD_PARALLEL:=1
 
+HOST_FIXUP:=autoreconf
+
 include $(INCLUDE_DIR)/host-build.mk
 
+PKG_REMOVE_FILES :=
+
 HOST_CONFIGURE_ARGS += \
 	--disable-shared \
 	--enable-elf64