From: Felix Fietkau <nbd@openwrt.org>
Date: Wed, 19 Nov 2014 20:16:50 +0000 (+0000)
Subject: build: allow AutoLoad and AutoProbe to specify modules not included in the package
X-Git-Url: http://git.cdn.openwrt.org/?a=commitdiff_plain;h=ab92a23394ce9563877be89b17cdc28e1d7d9e25;p=openwrt%2Fstaging%2Frobimarko.git

build: allow AutoLoad and AutoProbe to specify modules not included in the package

On out-of-tree modules depending on other out-of-tree modules from a
different tree, module dependencies are not filled properly.
This change helps with adding those dependencies in the AutoLoad call

Signed-off-by: Felix Fietkau <nbd@openwrt.org>

SVN-Revision: 43323
---

diff --git a/include/kernel.mk b/include/kernel.mk
index ae2dcc3fd9..28c8cf8974 100644
--- a/include/kernel.mk
+++ b/include/kernel.mk
@@ -84,10 +84,8 @@ define ModuleAutoLoad
 		boot="$$$$$$$$2"; \
 		shift 2; \
 		for mod in $$$$$$$$mods; do \
-			if [ -e $(2)/$(MODULES_SUBDIR)/$$$$$$$$mod.ko ]; then \
-				mkdir -p $(2)/etc/modules.d; \
-				echo "$$$$$$$$mod" >> $(2)/etc/modules.d/$(1); \
-			fi; \
+			mkdir -p $(2)/etc/modules.d; \
+			echo "$$$$$$$$mod" >> $(2)/etc/modules.d/$(1); \
 		done; \
 		if [ -e $(2)/etc/modules.d/$(1) ]; then \
 			if [ "$$$$$$$$boot" = "1" ]; then \
@@ -103,10 +101,8 @@ define ModuleAutoLoad
 		boot="$$$$$$$$3"; \
 		shift 3; \
 		for mod in $$$$$$$$mods; do \
-			if [ -e $(2)/$(MODULES_SUBDIR)/$$$$$$$$mod.ko ]; then \
-				mkdir -p $(2)/etc/modules.d; \
-				echo "$$$$$$$$mod" >> $(2)/etc/modules.d/$$$$$$$$priority-$(1); \
-			fi; \
+			mkdir -p $(2)/etc/modules.d; \
+			echo "$$$$$$$$mod" >> $(2)/etc/modules.d/$$$$$$$$priority-$(1); \
 		done; \
 		if [ -e $(2)/etc/modules.d/$$$$$$$$priority-$(1) ]; then \
 			if [ "$$$$$$$$boot" = "1" ]; then \