From: Gabor Juhos <juhosg@openwrt.org>
Date: Sat, 7 Sep 2013 11:40:45 +0000 (+0000)
Subject: ar71xx: use the lzma loader for the WRT160NL
X-Git-Url: http://git.cdn.openwrt.org/?a=commitdiff_plain;h=abad211388a0b33c488ae93e7ef6b690d8ca4813;p=openwrt%2Fstaging%2Fldir.git

ar71xx: use the lzma loader for the WRT160NL

Partition layout before:
  0x000000040000-0x0000001a0000 : "kernel"
  0x0000001a0000-0x0000007e0000 : "rootfs"
  mtd: partition "rootfs" set to be root filesystem
  mtd: partition "rootfs_data" created automatically, ofs=0x350000, len=0x490000
  0x000000350000-0x0000007e0000 : "rootfs_data"

after:
  0x000000040000-0x000000140000 : "kernel"
  0x000000140000-0x0000007e0000 : "rootfs"
  mtd: partition "rootfs" set to be root filesystem
  mtd: partition "rootfs_data" created automatically, ofs=0x2f0000, len=0x4f0000
  0x0000002f0000-0x0000007e0000 : "rootfs_data"

Signed-off-by: Gabor Juhos <juhosg@openwrt.org>

SVN-Revision: 37915
---

diff --git a/target/linux/ar71xx/image/Makefile b/target/linux/ar71xx/image/Makefile
index ac9c8b87e9..98f364dc0b 100644
--- a/target/linux/ar71xx/image/Makefile
+++ b/target/linux/ar71xx/image/Makefile
@@ -618,8 +618,8 @@ define Image/Build/TPLINK-LZMA/initramfs
 		-o $(call imgname,$(1),$(2))-uImage.bin
 endef
 
-
-Image/Build/CyberTAN/buildkernel=$(call MkuImageGzip,$(2),$(3))
+Image/Build/CyberTAN/loader=$(call Image/BuildLoader,$(1),gz,$(2),0x80060000)
+Image/Build/CyberTAN/buildkernel=$(call MkuImage,gzip,,$(KDIR)/loader-$(2).gz,$(KDIR_TMP)/vmlinux-$(2).uImage)
 
 define Image/Build/CyberTAN
 	$(STAGING_DIR_HOST)/bin/trx -o $(KDIR)/image.tmp -f $(KDIR_TMP)/vmlinux-$(2).uImage \