From: Rafał Miłecki <zajec5@gmail.com>
Date: Tue, 21 Apr 2015 08:19:53 +0000 (+0000)
Subject: bcm53xx: always use 4 MiB for TRX kernel partition to simplify upgrades
X-Git-Url: http://git.cdn.openwrt.org/?a=commitdiff_plain;h=ac6879caaa0e18015b8d4b3a99bdab4e0d758508;p=openwrt%2Fstaging%2Fldir.git

bcm53xx: always use 4 MiB for TRX kernel partition to simplify upgrades

Signed-off-by: Dan Haab <dhaab@luxul.com>

SVN-Revision: 45540
---

diff --git a/target/linux/bcm53xx/image/Makefile b/target/linux/bcm53xx/image/Makefile
index 4720aaf309..b3f2cd8127 100644
--- a/target/linux/bcm53xx/image/Makefile
+++ b/target/linux/bcm53xx/image/Makefile
@@ -31,12 +31,14 @@ define Build/mkfs/squashfs
 endef
 
 define Build/trx-nand
+	# kernel: always use 4 MiB (-28 B or TRX header) to allow upgrades even
+	#	  if it grows up between releases
 	$(STAGING_DIR_HOST)/bin/trx \
 		-o $@ \
 		-m 33554432 \
-		-f $(word 1,$^) \
-		-a 0x20000 -f $(KDIR)/root-block-0x20000-min-0x800.ubi \
-		-a 0x20000 -A $(KDIR)/fs_mark
+		-f $(word 1,$^) -a 0x20000 -b 0x400000 \
+		-f $(KDIR)/root-block-0x20000-min-0x800.ubi -a 0x20000 \
+		-A $(KDIR)/fs_mark
 endef
 
 define Build/netgear-chk