From: John Crispin <john@openwrt.org>
Date: Thu, 11 Dec 2014 20:41:51 +0000 (+0000)
Subject: oxnas: use ARM BCJ filter for XZ decompression
X-Git-Url: http://git.cdn.openwrt.org/?a=commitdiff_plain;h=ad35bcc41e54a3444c3901eec86f255d3841b941;p=openwrt%2Fstaging%2Fneocturne.git

oxnas: use ARM BCJ filter for XZ decompression

Restoring the config for kernel 3.14 didn't contain that change already
made to config-3.18.
It is needed to make squashfs in the kernel match the compression settings
for ARCH=arm in the framework.
If set to ARMTHUMB, boot fails due to squashfs being unreadable if the
filesystem was generated for wth ARM BCJ filter.

in include/image.mk:    BCJ_FILTER:=-Xbcj $(LINUX_KARCH)
Thus the ARM filter is used for all ARM targets.

Signed-off-by: Daniel Golle <daniel@makrotopia.org>

SVN-Revision: 43640
---

diff --git a/target/linux/oxnas/config-3.14 b/target/linux/oxnas/config-3.14
index 727d81e2f4..086f870cea 100644
--- a/target/linux/oxnas/config-3.14
+++ b/target/linux/oxnas/config-3.14
@@ -339,7 +339,7 @@ CONFIG_VM_EVENT_COUNTERS=y
 CONFIG_WATCHDOG_CORE=y
 CONFIG_WATCHDOG_NOWAYOUT=y
 CONFIG_XPS=y
-CONFIG_XZ_DEC_ARMTHUMB=y
+CONFIG_XZ_DEC_ARM=y
 CONFIG_XZ_DEC_BCJ=y
 CONFIG_ZBOOT_ROM_BSS=0
 CONFIG_ZBOOT_ROM_TEXT=0