From: Paul Spooren <mail@aparcar.org>
Date: Sun, 5 Aug 2018 03:17:29 +0000 (+0900)
Subject: imagebuilder: manifest function show stderr
X-Git-Url: http://git.cdn.openwrt.org/?a=commitdiff_plain;h=ad5c2897ec054b80549e526ef639dd75548d4747;p=openwrt%2Fstaging%2Fansuel.git

imagebuilder: manifest function show stderr

This really simplifies debugging, if a package is not found or a feed is
not reachable, a proper stderr is printed. Currently it would only say
`_call_manifest` failed.

Signed-off-by: Paul Spooren <mail@aparcar.org>
---

diff --git a/target/imagebuilder/files/Makefile b/target/imagebuilder/files/Makefile
index e0c0132b85..76ea19028e 100644
--- a/target/imagebuilder/files/Makefile
+++ b/target/imagebuilder/files/Makefile
@@ -119,8 +119,8 @@ _call_image: staging_dir/host/.prereq-build
 _call_manifest: FORCE
 	rm -rf $(TARGET_DIR)
 	mkdir -p $(TARGET_DIR) $(BIN_DIR) $(TMP_DIR) $(DL_DIR)
-	$(MAKE) package_reload >/dev/null 2>/dev/null
-	$(MAKE) package_install >/dev/null 2>/dev/null
+	$(MAKE) package_reload >/dev/null
+	$(MAKE) package_install >/dev/null
 	$(OPKG) list-installed
 
 package_index: FORCE