From: Florian Fainelli <florian@openwrt.org>
Date: Wed, 12 Apr 2006 14:48:36 +0000 (+0000)
Subject: Move ueagle to the main kernel config since it is in stock kernel Add Zydas ZD1211... 
X-Git-Url: http://git.cdn.openwrt.org/?a=commitdiff_plain;h=ad8842b945a0a27606d055e1a67b048e009e5843;p=openwrt%2Fstaging%2Fthess.git

Move ueagle to the main kernel config since it is in stock kernel Add Zydas ZD1211 driver, needs testing, closes #249 Change MTX-1 platform name for AU1000 in order to have a unique platform naming

SVN-Revision: 3626
---

diff --git a/openwrt/target/Config.in b/openwrt/target/Config.in
index 310105b70b..2c486eec76 100644
--- a/openwrt/target/Config.in
+++ b/openwrt/target/Config.in
@@ -60,8 +60,8 @@ config BR2_LINUX_2_6_X86
 	  Build firmware images for x86 based boards
 	  (e.g. Soekris net4521 and net4801, PC Engines WRAP...)
 
-config BR2_LINUX_2_6_MTX-1
-	bool "mtx1 [2.6]"
+config BR2_LINUX_2_6_AU1000
+	bool "au1000 [2.6]"
 	select BR2_mipsel
 	select BR2_LINUX_2_6
 	select BR2_LINUX_PCMCIA_SUPPORT
diff --git a/openwrt/target/linux/Config.in b/openwrt/target/linux/Config.in
index c9571291d3..87cd436ddb 100644
--- a/openwrt/target/linux/Config.in
+++ b/openwrt/target/linux/Config.in
@@ -619,7 +619,7 @@ config BR2_PACKAGE_KMOD_USB
 config BR2_PACKAGE_KMOD_USB_UHCI 
 	prompt   "kmod-usb-uhci................... Support for UHCI controllers"
 	tristate
-	default n if BR2_LINUX_2_6_MTX-1
+	default n if BR2_LINUX_2_6_AU1000
 	depends BR2_PACKAGE_KMOD_USB
 	select BR2_PACKAGE_KMOD_USB_CONTROLLER
 
@@ -633,7 +633,7 @@ config BR2_PACKAGE_KMOD_USB_OHCI
 config BR2_PACKAGE_KMOD_USB2
 	prompt   "kmod-usb2....................... Support for USB 2.0 controllers"
 	tristate
-	default n if BR2_LINUX_2_6_MTX-1
+	default n if BR2_LINUX_2_6_AU1000
 	depends BR2_PACKAGE_KMOD_USB
 	select BR2_PACKAGE_KMOD_USB_CONTROLLER
 
diff --git a/openwrt/target/linux/Makefile b/openwrt/target/linux/Makefile
index f40a99cf53..9f25fd721e 100644
--- a/openwrt/target/linux/Makefile
+++ b/openwrt/target/linux/Makefile
@@ -92,4 +92,4 @@ $(eval $(call kernel_template,2.6,brcm,2_6_BRCM))
 $(eval $(call kernel_template,2.6,x86,2_6_X86))
 $(eval $(call kernel_template,2.4,ar531x,2_4_AR531X))
 $(eval $(call kernel_template,2.6,aruba,2_6_ARUBA))
-$(eval $(call kernel_template,2.6,au1000,2_6_MTX-1))
+$(eval $(call kernel_template,2.6,au1000,2_6_AU1000))
diff --git a/openwrt/target/linux/au1000-2.6/config b/openwrt/target/linux/au1000-2.6/config
index 7245625b0e..be9db372a5 100644
--- a/openwrt/target/linux/au1000-2.6/config
+++ b/openwrt/target/linux/au1000-2.6/config
@@ -1386,7 +1386,7 @@ CONFIG_USB_SERIAL_PL2303=m
 CONFIG_USB_ATM=m
 CONFIG_USB_SPEEDTOUCH=m
 # CONFIG_USB_CXACRU is not set
-# CONFIG_USB_UEAGLEATM is not set
+CONFIG_USB_UEAGLEATM=m
 # CONFIG_USB_XUSBATM is not set
 
 #
diff --git a/openwrt/target/linux/brcm-2.6/config b/openwrt/target/linux/brcm-2.6/config
index 81092f3783..725ffbb03b 100644
--- a/openwrt/target/linux/brcm-2.6/config
+++ b/openwrt/target/linux/brcm-2.6/config
@@ -1448,7 +1448,7 @@ CONFIG_USB_SERIAL_PL2303=m
 CONFIG_USB_ATM=m
 CONFIG_USB_SPEEDTOUCH=m
 # CONFIG_USB_CXACRU is not set
-# CONFIG_USB_UEAGLEATM is not set
+CONFIG_USB_UEAGLEATM=m
 # CONFIG_USB_XUSBATM is not set
 
 #
diff --git a/openwrt/target/linux/package/zd1211/Config.in b/openwrt/target/linux/package/zd1211/Config.in
new file mode 100644
index 0000000000..2c36a10b01
--- /dev/null
+++ b/openwrt/target/linux/package/zd1211/Config.in
@@ -0,0 +1,10 @@
+config BR2_PACKAGE_KMOD_ZD1211
+	prompt "kmod-zd12111...................... Driver for Zydas 1211 based devices"
+	tristate
+	default m if CONFIG_DEVEL
+	help
+	  Linux driver for the ZyDAS ZD1211 802.11b/g USB-WLAN-Chip. 
+	  Initially contributed by ZyDAS, this driver is actively maintained 
+	  by the open source community.
+	
+	  http://zd1211.ath.cx/
diff --git a/openwrt/target/linux/package/zd1211/Makefile b/openwrt/target/linux/package/zd1211/Makefile
new file mode 100644
index 0000000000..e357af768e
--- /dev/null
+++ b/openwrt/target/linux/package/zd1211/Makefile
@@ -0,0 +1,49 @@
+# $Id: Makefile 3297 2006-03-02 23:42:52Z florian $
+
+include $(TOPDIR)/rules.mk
+include ../../rules.mk
+
+PKG_NAME:=zd1211
+PKG_VERSION:=r69
+PKG_RELEASE:=1
+PKG_MD5SUM:=c14133a3d5b27927402a492e84d2467a
+
+PKG_SOURCE_URL:=http://zd1211.ath.cx/download/
+PKG_SOURCE:=$(PKG_NAME)-driver-$(PKG_VERSION).tgz
+PKG_CAT:=zcat
+
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-driver-$(PKG_VERSION)
+PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+
+include $(TOPDIR)/package/rules.mk
+
+$(eval $(call PKG_template,KMOD_ZD1211,kmod-$(PKG_NAME),$(LINUX_VERSION)+$(PKG_VERSION)-$(BOARD)-$(PKG_RELEASE),$(ARCH),kernel ($(LINUX_VERSION)-$(BOARD)-$(LINUX_RELEASE))))
+
+$(PKG_BUILD_DIR)/.configured:
+	touch $@
+
+$(PKG_BUILD_DIR)/.built: 
+	$(MAKE) -C $(PKG_BUILD_DIR) \
+		ARCH="$(LINUX_KARCH)" \
+		CROSS_COMPILE="$(TARGET_CROSS)" \
+		CC="$(TARGET_CC)" \
+		CPP="$(TARGET_CC)" \
+		LD="$(TARGET_CROSS)ld" \
+		STAGING_DIR=$(STAGING_DIR) \
+		KERNELVERSION="$(KERNEL)" \
+		MODPATH="$(MODULES_DIR)" \
+		KERNEL_SOURCE="$(LINUX_DIR)" \
+		all
+	$(TARGET_CC) $(PKG_BUILD_DIR)/apdbg.c -o $(PKG_BUILD_DIR)/apdbg
+	touch $@
+
+$(IPKG_KMOD_ZD1211):
+	install -m0755 -d $(IDIR_KMOD_ZD1211)/lib/modules/$(LINUX_VERSION) \
+			  $(IDIR_KMOD_ZD1211)/usr/sbin
+	$(CP) $(PKG_BUILD_DIR)/zd1211.$(LINUX_KMOD_SUFFIX) \
+		$(IDIR_KMOD_ZD1211)/lib/modules/$(LINUX_VERSION)/
+	$(CP) $(PKG_BUILD_DIR)/apdbg $(IDIR_KMOD_ZD1211)/usr/sbin/
+	$(CP) $(PKG_BUILD_DIR)/sta $(IDIR_KMOD_ZD1211)/usr/sbin/$(PKG_NAME)-sta
+	$(RSTRIP_KMOD) $(IDIR_KMOD_ZD1211)
+	$(IPKG_BUILD) $(IDIR_KMOD_ZD1211) $(PACKAGE_DIR)
+
diff --git a/openwrt/target/linux/package/zd1211/ipkg/kmod-zd1211.control b/openwrt/target/linux/package/zd1211/ipkg/kmod-zd1211.control
new file mode 100644
index 0000000000..314fc91650
--- /dev/null
+++ b/openwrt/target/linux/package/zd1211/ipkg/kmod-zd1211.control
@@ -0,0 +1,4 @@
+Package: kmod-zd1211
+Section: net
+Description: Driver for Zydas 1211 based devices.
+Priority: optional