From: Michael Büsch <mb@bu3sch.de>
Date: Mon, 7 Mar 2011 16:14:10 +0000 (+0000)
Subject: omap24xx: Add config option for n810 bluetooth driver
X-Git-Url: http://git.cdn.openwrt.org/?a=commitdiff_plain;h=b09817a5e7ebd187632c80cc7a423d22b7d4a220;p=openwrt%2Fstaging%2Faparcar.git

omap24xx: Add config option for n810 bluetooth driver

SVN-Revision: 25934
---

diff --git a/package/kernel/modules/other.mk b/package/kernel/modules/other.mk
index 0ecc7b3786..aba1c6b7d1 100644
--- a/package/kernel/modules/other.mk
+++ b/package/kernel/modules/other.mk
@@ -55,6 +55,22 @@ endef
 $(eval $(call KernelPackage,bluetooth))
 
 
+define KernelPackage/bluetooth-hci-h4p
+  SUBMENU:=$(OTHER_MENU)
+  TITLE:=HCI driver with H4 Nokia extensions
+  DEPENDS:=@TARGET_omap24xx +kmod-bluetooth
+  KCONFIG:=CONFIG_BT_HCIH4P
+  FILES:=$(LINUX_DIR)/drivers/bluetooth/hci_h4p/hci_h4p.ko
+  AUTOLOAD:=$(call AutoLoad,91,hci_h4p)
+endef
+
+define KernelPackage/bluetooth-hci-h4p/description
+  HCI driver with H4 Nokia extensions
+endef
+
+$(eval $(call KernelPackage,bluetooth-hci-h4p))
+
+
 define KernelPackage/cpu-msr
   SUBMENU:=$(OTHER_MENU)
   TITLE:=x86 CPU MSR support