From: Felix Fietkau <nbd@openwrt.org>
Date: Tue, 2 Sep 2008 10:57:56 +0000 (+0000)
Subject: get rid of a shell warning if md5sum is not found
X-Git-Tag: reboot~25646
X-Git-Url: http://git.cdn.openwrt.org/?a=commitdiff_plain;h=b0d8473bf4dc49c5e49f9151a803402af1223a32;p=openwrt%2Fopenwrt.git

get rid of a shell warning if md5sum is not found

SVN-Revision: 12494
---

diff --git a/include/scan.mk b/include/scan.mk
index 19350b612b..7b818e8aba 100644
--- a/include/scan.mk
+++ b/include/scan.mk
@@ -52,7 +52,7 @@ $(TMP_DIR)/info/.files-$(SCAN_TARGET).mk: $(FILELIST)
 $(TARGET_STAMP)::
 	+( \
 		$(NO_TRACE_MAKE) $(FILELIST); \
-		MD5SUM=$$(cat $(FILELIST) | (md5sum || md5) | awk '{print $$1}'); \
+		MD5SUM=$$(cat $(FILELIST) | (md5sum || md5) 2>/dev/null | awk '{print $$1}'); \
 		[ -f "$@.$$MD5SUM" ] || { \
 			rm -f $@.*; \
 			touch $@.$$MD5SUM; \