From: Nicolas Thill <nico@openwrt.org>
Date: Tue, 17 Jan 2006 13:26:00 +0000 (+0000)
Subject: fix alsa build on x86 (closes: #201)
X-Git-Url: http://git.cdn.openwrt.org/?a=commitdiff_plain;h=b1a2c6e7f8af0abf4c3b578de5a42629349b8438;p=openwrt%2Fstaging%2Flinusw.git

fix alsa build on x86 (closes: #201)

SVN-Revision: 3001
---

diff --git a/openwrt/target/linux/package/alsa/Makefile b/openwrt/target/linux/package/alsa/Makefile
index dd743874c5..11b12cab5d 100644
--- a/openwrt/target/linux/package/alsa/Makefile
+++ b/openwrt/target/linux/package/alsa/Makefile
@@ -17,7 +17,7 @@ PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
 include $(TOPDIR)/package/rules.mk
 
 ifeq ($(LINUX_KARCH),i386)
-KERNEL_C_INCS:= -I$(LINUX_DIR)/include/asm-i386/mach-generic
+KERNEL_C_INCS:= -I$(LINUX_DIR)/include/asm-i386/mach-generic -I$(LINUX_DIR)/include/asm-i386/mach-default
 KERNEL_C_OPTS:= -Os -mpreferred-stack-boundary=2 -march=i486 -fno-unit-at-a-time
 endif
 ifeq ($(LINUX_KARCH),mips)