From: Felix Fietkau <nbd@openwrt.org>
Date: Sat, 18 Oct 2014 19:25:24 +0000 (+0000)
Subject: toolchain: fix binutils broken symlink
X-Git-Tag: reboot~5616
X-Git-Url: http://git.cdn.openwrt.org/?a=commitdiff_plain;h=b537205ea2892cd23da6f75730dae04da8aad128;p=openwrt%2Fstaging%2Fpepe2k.git

toolchain: fix binutils broken symlink

The Makefile for binutils creates a broken symlink to "binutils-linaro" in
"trunk/build_dir/toolchain-<target>_gcc-4.9-linaro_uClibc-0.9.33.2".
Modify the Makefile to point the symlink to the correct directory.

Signed-off-by: Nathan Hintz <nlhintz@hotmail.com>

SVN-Revision: 42954
---

diff --git a/toolchain/binutils/Makefile b/toolchain/binutils/Makefile
index 567f88a854..b88fbd8b2c 100644
--- a/toolchain/binutils/Makefile
+++ b/toolchain/binutils/Makefile
@@ -63,7 +63,7 @@ endif
 
 define Host/Prepare
 	$(call Host/Prepare/Default)
-	ln -snf $(PKG_NAME)-$(PKG_VERSION) $(BUILD_DIR_TOOLCHAIN)/$(PKG_NAME)
+	ln -snf $(notdir $(HOST_BUILD_DIR)) $(BUILD_DIR_TOOLCHAIN)/$(PKG_NAME)
 	$(CP) $(SCRIPT_DIR)/config.{guess,sub} $(HOST_BUILD_DIR)/
 endef