From: Piotr Dymacz <pepe2k@gmail.com>
Date: Sun, 28 Mar 2021 22:48:15 +0000 (+0200)
Subject: uboot-imx: set BUILD_SUBTARGET to 'cortexa9'
X-Git-Url: http://git.cdn.openwrt.org/?a=commitdiff_plain;h=b6b09bf00cff38cfc8869053afb3dc26e2150edb;p=openwrt%2Fstaging%2Fxback.git

uboot-imx: set BUILD_SUBTARGET to 'cortexa9'

All currently supported devices belong to the imx/cortexa9 subtarget.

Signed-off-by: Piotr Dymacz <pepe2k@gmail.com>
---

diff --git a/package/boot/uboot-imx/Makefile b/package/boot/uboot-imx/Makefile
index 9ca4d55a1c..2faa48bd73 100644
--- a/package/boot/uboot-imx/Makefile
+++ b/package/boot/uboot-imx/Makefile
@@ -24,6 +24,7 @@ define U-Boot/apalis_imx6
   NAME:=Toradex Apalis
   UBOOT_IMAGE:=SPL u-boot.img u-boot-with-spl.imx
   UBOOT_MAKE_FLAGS:=SPL u-boot.img u-boot-with-spl.imx
+  BUILD_SUBTARGET:=cortexa9
   BUILD_DEVICES:=toradex_apalis
 endef
 
@@ -31,11 +32,13 @@ define U-Boot/mx6cuboxi
   NAME:=SolidRun Cubox-i boards
   UBOOT_IMAGE:=SPL u-boot.img
   UBOOT_MAKE_FLAGS:=SPL u-boot.img
+  BUILD_SUBTARGET:=cortexa9
   BUILD_DEVICES:=solidrun_cubox-i
 endef
 
 define U-Boot/wandboard
   NAME:=Wandboard Dual Lite/Quad/Solo
+  BUILD_SUBTARGET:=cortexa9
   BUILD_DEVICES:=wandboard_dual
 endef