From: Florian Fainelli <florian@openwrt.org>
Date: Thu, 27 Jun 2013 19:58:16 +0000 (+0000)
Subject: buildroot: workaround broken syntax highlighting
X-Git-Tag: reboot~10135
X-Git-Url: http://git.cdn.openwrt.org/?a=commitdiff_plain;h=b729d41d64a360ad4082c7a1e20a74d8c1c9e62e;p=openwrt%2Fstaging%2Fchunkeey.git

buildroot: workaround broken syntax highlighting

GNU Make's subst is always breaking syntax highlighting with at least
vim add the right comments to workaround it.

Signed-off-by: Florian Fainelli <florian@openwrt.org>

SVN-Revision: 37046
---

diff --git a/include/kernel-defaults.mk b/include/kernel-defaults.mk
index 9a4dd90ed5..8ad31dd73a 100644
--- a/include/kernel-defaults.mk
+++ b/include/kernel-defaults.mk
@@ -116,6 +116,7 @@ OBJCOPY_STRIP = -R .reginfo -R .notes -R .note -R .comment -R .mdebug -R .note.g
 define Kernel/CompileImage/Default
 	$(if $(CONFIG_TARGET_ROOTFS_INITRAMFS),,rm -f $(TARGET_DIR)/init)
 	+$(MAKE) $(KERNEL_MAKEOPTS) $(subst ",,$(KERNELNAME))
+	#")
 	$(KERNEL_CROSS)objcopy -O binary $(OBJCOPY_STRIP) -S $(LINUX_DIR)/vmlinux $(LINUX_KERNEL)
 	$(KERNEL_CROSS)objcopy $(OBJCOPY_STRIP) -S $(LINUX_DIR)/vmlinux $(KERNEL_BUILD_DIR)/vmlinux.elf
 endef