From: Jo-Philipp Wich <jow@openwrt.org>
Date: Thu, 19 Jan 2012 12:19:28 +0000 (+0000)
Subject: abort built in prereq target if there is no site config file for the current target
X-Git-Tag: reboot~15136
X-Git-Url: http://git.cdn.openwrt.org/?a=commitdiff_plain;h=b81354d8286386adc010d3178bd153bf0f6fc661;p=openwrt%2Fstaging%2Fchunkeey.git

abort built in prereq target if there is no site config file for the current target

SVN-Revision: 29798
---

diff --git a/Makefile b/Makefile
index 4d5d7885e0..44b4e944eb 100644
--- a/Makefile
+++ b/Makefile
@@ -78,6 +78,12 @@ endif
 
 # check prerequisites before starting to build
 prereq: $(target/stamp-prereq) tmp/.prereq_packages
+	@if [ ! -f "$(INCLUDE_DIR)/site/$(REAL_GNU_TARGET_NAME)" ]; then \
+		echo 'ERROR: Missing site config for target "$(REAL_GNU_TARGET_NAME)" !'; \
+		echo '       The missing file will cause configure scripts to fail during compilation.'; \
+		echo '       Please provide a "$(INCLUDE_DIR)/site/$(REAL_GNU_TARGET_NAME)" file and restart the build.'; \
+		exit 1; \
+	fi
 
 prepare: .config $(tools/stamp-install) $(toolchain/stamp-install)
 world: prepare $(target/stamp-compile) $(package/stamp-cleanup) $(package/stamp-compile) $(package/stamp-install) $(package/stamp-rootfs-prepare) $(target/stamp-install) FORCE