From: Hauke Mehrtens <hauke@hauke-m.de>
Date: Sat, 22 Oct 2022 00:26:05 +0000 (+0200)
Subject: kernel: x86: Add glue_helper.ko only on kernel < 5.12
X-Git-Url: http://git.cdn.openwrt.org/?a=commitdiff_plain;h=b9b0407901f6518a0f5c4825208cff542f4b80cd;p=openwrt%2Fstaging%2Fjogo.git

kernel: x86: Add glue_helper.ko only on kernel < 5.12

This module was removed with kernel 5.12.
This fixes the build of the x86 target.

Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
---

diff --git a/package/kernel/linux/modules/crypto.mk b/package/kernel/linux/modules/crypto.mk
index f8af5f0a3b..83048e50d3 100644
--- a/package/kernel/linux/modules/crypto.mk
+++ b/package/kernel/linux/modules/crypto.mk
@@ -727,10 +727,10 @@ ifndef CONFIG_TARGET_x86_64
     FILES+= \
 	$(LINUX_DIR)/arch/x86/crypto/twofish-i586.ko \
 	$(LINUX_DIR)/arch/x86/crypto/serpent-sse2-i586.ko \
-	$(LINUX_DIR)/arch/x86/crypto/glue_helper.ko \
+	$(LINUX_DIR)/arch/x86/crypto/glue_helper.ko@lt5.12 \
 	$(LINUX_DIR)/crypto/cryptd.ko \
 	$(LINUX_DIR)/crypto/crypto_simd.ko
-    AUTOLOAD+= $(call AutoLoad,10,cryptd glue_helper \
+    AUTOLOAD+= $(call AutoLoad,10,cryptd glue_helper@lt5.12 \
 	serpent-sse2-i586 twofish-i586 blowfish_generic)
   endef
 endif