From: Jo-Philipp Wich <jow@openwrt.org>
Date: Thu, 28 May 2015 13:25:21 +0000 (+0000)
Subject: at91: fix imagebuilder
X-Git-Url: http://git.cdn.openwrt.org/?a=commitdiff_plain;h=ba9f34a38981305e95b0b84df717acdd89d5c27a;p=openwrt%2Fstaging%2Fldir.git

at91: fix imagebuilder

Signed-off-by: Jo-Philipp Wich <jow@openwrt.org>

SVN-Revision: 45806
---

diff --git a/target/linux/at91/image/Makefile b/target/linux/at91/image/Makefile
index 49e2bee5c1..4e472f23db 100644
--- a/target/linux/at91/image/Makefile
+++ b/target/linux/at91/image/Makefile
@@ -24,6 +24,7 @@ define Build/Compile
 endef
 
 define Image/Prepare
+	cp $(LINUX_DIR)/arch/arm/boot/Image $(KDIR)/Image
 	cp $(LINUX_DIR)/arch/arm/boot/zImage $(KDIR)/zImage
 endef
 
@@ -89,9 +90,9 @@ endef
 
 define Image/BuildKernel
 	mkimage -A arm -T kernel -C none -a 0x20008000 -e 0x20008000 -n linux-2.6 \
-		-d $(LINUX_DIR)/arch/arm/boot/Image $(BIN_DIR)/uImage
+		-d $(KDIR)/Image $(BIN_DIR)/$(IMG_PREFIX)-uImage
 	if [ $(CONFIG_FLEXIBITY_ROOT) ]; then \
-		$(INSTALL_BIN) $(BIN_DIR)/uImage $(TARGET_DIR)/uImage ; \
+		$(INSTALL_BIN) $(BIN_DIR)/$(IMG_PREFIX)-uImage $(TARGET_DIR)/uImage ; \
 	fi
 	$(call Image/Build/Kernel/$(PROFILE))
 endef