From: Nicolas Thill <nico@openwrt.org>
Date: Fri, 16 Apr 2010 11:03:50 +0000 (+0000)
Subject: package/kexec-tools: move configuration in submenu, rename 'kexec-config.in' in ... 
X-Git-Tag: reboot~20201
X-Git-Url: http://git.cdn.openwrt.org/?a=commitdiff_plain;h=bbbdc421c7a8279d82f05af06b17b46d08094a6a;p=openwrt%2Fstaging%2Fchunkeey.git

package/kexec-tools: move configuration in submenu, rename 'kexec-config.in' in 'Config.in' for coherency

SVN-Revision: 20916
---

diff --git a/package/kexec-tools/Config.in b/package/kexec-tools/Config.in
new file mode 100644
index 0000000000..60c819d798
--- /dev/null
+++ b/package/kexec-tools/Config.in
@@ -0,0 +1,21 @@
+menu "Configuration"
+	depends on PACKAGE_kexec-tools
+
+config KEXEC_TOOLS_TARGET_NAME
+	string
+	prompt "Target name for kexec kernel"
+	default EXTRA_TARGET_ARCH_NAME	if powerpc64
+	default ARCH
+	help
+	  Defines the target type of the kernels that kexec deals
+	  with. This should be the target specification of
+	  the kernel you're booting.
+
+config KEXEC_TOOLS_kdump
+	bool
+	prompt "kdump support"
+	default n
+	help
+	  Include the kdump utility.
+
+endmenu
diff --git a/package/kexec-tools/Makefile b/package/kexec-tools/Makefile
index d350bb2c8b..978bb6fd50 100644
--- a/package/kexec-tools/Makefile
+++ b/package/kexec-tools/Makefile
@@ -34,7 +34,7 @@ define Package/kexec-tools/description
 endef
 
 define Package/kexec-tools/config
-	source "$(SOURCE)/kexec-config.in"
+	source "$(SOURCE)/Config.in"
 endef
 
 KEXEC_TARGET_NAME:=$(call qstrip,$(CONFIG_KEXEC_TOOLS_TARGET_NAME))-linux-$(TARGET_SUFFIX)
diff --git a/package/kexec-tools/kexec-config.in b/package/kexec-tools/kexec-config.in
deleted file mode 100644
index 25fed1b7cd..0000000000
--- a/package/kexec-tools/kexec-config.in
+++ /dev/null
@@ -1,19 +0,0 @@
-
-config KEXEC_TOOLS_TARGET_NAME
-	string
-	prompt "Target name for kexec kernel" if PACKAGE_kexec-tools
-	default EXTRA_TARGET_ARCH_NAME	if powerpc64
-	default ARCH
-	help
-	  Defines the target type of the kernels that kexec deals
-	  with. This should be the target specification of
-	  the kernel you're booting.
-
-config KEXEC_TOOLS_kdump
-	bool
-	prompt "kdump support"
-	depends on PACKAGE_kexec-tools
-	default n
-	help
-	  Include the kdump utility.
-