From: Daniel Golle <daniel@makrotopia.org>
Date: Sat, 9 Nov 2024 23:32:05 +0000 (+0100)
Subject: include: meson.mk: honor CONFIG_DEBUG
X-Git-Url: http://git.cdn.openwrt.org/?a=commitdiff_plain;h=be3e7a84bd37f29e14e4c6a89b8c79bc9808c36c;p=openwrt%2Fstaging%2Fansuel.git

include: meson.mk: honor CONFIG_DEBUG

Set buildtype according to CONFIG_DEBUG.

Signed-off-by: Daniel Golle <daniel@makrotopia.org>
---

diff --git a/include/meson.mk b/include/meson.mk
index 2a20c2bd6b..ff452d8b01 100644
--- a/include/meson.mk
+++ b/include/meson.mk
@@ -124,7 +124,7 @@ define Build/Configure/Meson
 	$(call Meson/CreateCrossFile,$(PKG_BUILD_DIR)/openwrt-cross.txt)
 	$(call Meson, \
 		setup \
-		--buildtype plain \
+		--buildtype $(if $(CONFIG_DEBUG),debug,plain) \
 		--native-file $(PKG_BUILD_DIR)/openwrt-native.txt \
 		--cross-file $(PKG_BUILD_DIR)/openwrt-cross.txt \
 		-Ddefault_library=both \