From: Jo-Philipp Wich <jow@openwrt.org>
Date: Fri, 23 Mar 2012 11:26:47 +0000 (+0000)
Subject: [package] dnsmasq: add missing config_get, localize variables, bump package revision
X-Git-Url: http://git.cdn.openwrt.org/?a=commitdiff_plain;h=be6f5990872f2acfc2bcab2904d8ef5143207abe;p=openwrt%2Fsvn-archive%2Farchive.git

[package] dnsmasq: add missing config_get, localize variables, bump package revision

SVN-Revision: 31058
---

diff --git a/package/dnsmasq/Makefile b/package/dnsmasq/Makefile
index a23e9ff795..9fc70b3daf 100644
--- a/package/dnsmasq/Makefile
+++ b/package/dnsmasq/Makefile
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006-2011 OpenWrt.org
+# Copyright (C) 2006-2012 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=dnsmasq
 PKG_VERSION:=2.59
-PKG_RELEASE:=2
+PKG_RELEASE:=3
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://thekelleys.org.uk/dnsmasq
diff --git a/package/dnsmasq/files/dnsmasq.init b/package/dnsmasq/files/dnsmasq.init
index edd22ad3eb..75a57e72c3 100644
--- a/package/dnsmasq/files/dnsmasq.init
+++ b/package/dnsmasq/files/dnsmasq.init
@@ -372,7 +372,9 @@ dhcp_srv_add() {
 
 dhcp_mx_add() {
 	local cfg="$1"
+	local domain relay pref
 
+	config_get domain "$cfg" domain
 	[ -n "$domain" ] || return 0
 
 	config_get relay "$cfg" relay