From: Mark King <mark@vemek.co>
Date: Sun, 25 Sep 2022 20:53:52 +0000 (+0100)
Subject: ramips: enable LZMA loader to fix Linksys RE6500 boot
X-Git-Url: http://git.cdn.openwrt.org/?a=commitdiff_plain;h=bf5b1a53d4ff3f1d742f9ece1ab16555280417ec;p=openwrt%2Fstaging%2Fjogo.git

ramips: enable LZMA loader to fix Linksys RE6500 boot

At some point after 21.02.3 and before 22.03.0, the size limits of the
Linksys RE6500 were reached and prevent booting from the 22.03.0 release
or builds of current SNAPSHOT. This patch allows builds of master to boot
again and has been tested on my device.

Fixes: #8577

Signed-off-by: Mark King <mark@vemek.co>
---

diff --git a/target/linux/ramips/image/mt7621.mk b/target/linux/ramips/image/mt7621.mk
index d7bbedac05..92fc9ec12e 100644
--- a/target/linux/ramips/image/mt7621.mk
+++ b/target/linux/ramips/image/mt7621.mk
@@ -1270,6 +1270,7 @@ TARGET_DEVICES += linksys_ea8100-v2
 
 define Device/linksys_re6500
   $(Device/dsa-migration)
+  $(Device/uimage-lzma-loader)
   IMAGE_SIZE := 7872k
   DEVICE_VENDOR := Linksys
   DEVICE_MODEL := RE6500