From: John Crispin <john@openwrt.org>
Date: Sat, 23 May 2015 15:28:26 +0000 (+0000)
Subject: modules/usb: cleanup remove old module names
X-Git-Url: http://git.cdn.openwrt.org/?a=commitdiff_plain;h=c0b0ee9d9e6c66ab774502d79c07ef35092b9a18;p=openwrt%2Fsvn-archive%2Fopenwrt.git

modules/usb: cleanup remove old module names

delete cases for Kernel <3.10 (nop-usb-xceiv), <3.12 (phy-nop)

Signed-off-by: Dirk Neukirchen <dirkneukirchen@web.de>

SVN-Revision: 45733
---

diff --git a/package/kernel/linux/modules/usb.mk b/package/kernel/linux/modules/usb.mk
index 589894bcd1..f3c84e6f10 100644
--- a/package/kernel/linux/modules/usb.mk
+++ b/package/kernel/linux/modules/usb.mk
@@ -103,18 +103,8 @@ define KernelPackage/usb-phy-nop
   TITLE:=Support for USB NOP transceiver
   KCONFIG:=CONFIG_NOP_USB_XCEIV
   HIDDEN:=1
-ifneq ($(wildcard $(LINUX_DIR)/drivers/usb/phy/phy-generic.ko),)
   FILES:=$(LINUX_DIR)/drivers/usb/phy/phy-generic.ko
   AUTOLOAD:=$(call AutoLoad,43,phy-generic)
-else
-ifneq ($(wildcard $(LINUX_DIR)/drivers/usb/phy/phy-nop.ko),)
-  FILES:=$(LINUX_DIR)/drivers/usb/phy/phy-nop.ko
-  AUTOLOAD:=$(call AutoLoad,43,phy-nop)
-else
-  FILES:=$(LINUX_DIR)/drivers/usb/otg/nop-usb-xceiv.ko
-  AUTOLOAD:=$(call AutoLoad,43,nop-usb-xceiv)
-endif
-endif
   $(call AddDepends/usb)
 endef