From: Moritz Warning <moritzwarning@web.de>
Date: Wed, 10 Jul 2019 22:10:56 +0000 (+0200)
Subject: gemini: split up DEVICE_TITLE
X-Git-Url: http://git.cdn.openwrt.org/?a=commitdiff_plain;h=c1bf5d543242200f868352e8647a22bf0324b7a4;p=openwrt%2Fstaging%2Fblogic.git

gemini: split up DEVICE_TITLE

DEVICE_TITLE is split up into DEVICE_VENDOR, DEVICE_MODEL and DEVICE_VARIANT

Signed-off-by: Moritz Warning <moritzwarning@web.de>
---

diff --git a/target/linux/gemini/image/Makefile b/target/linux/gemini/image/Makefile
index ebcff633ea8a..e1b6941201a0 100644
--- a/target/linux/gemini/image/Makefile
+++ b/target/linux/gemini/image/Makefile
@@ -140,7 +140,8 @@ GEMINI_NAS_PACKAGES:=kmod-md-mod kmod-md-linear kmod-md-multipath \
 #   This will be flashed from OpenWrt userland anyways so we only need
 #   the minimum to make the boot loader happy.
 define Device/dlink_dir-685
-	DEVICE_TITLE := D-Link DIR-685 Xtreme N Storage Router
+	DEVICE_VENDOR := D-Link
+	DEVICE_MODEL := DIR-685 Xtreme N Storage Router
 	DEVICE_DTS := gemini-dlink-dir-685
 	DEVICE_PACKAGES := $(GEMINI_NAS_PACKAGES) \
 			kmod-rt2800-pci
@@ -152,7 +153,8 @@ endef
 TARGET_DEVICES += dlink_dir-685
 
 define Device/dlink_dns-313
-	DEVICE_TITLE := D-Link DNS-313 1-Bay Network Storage Enclosure
+	DEVICE_VENDOR := D-Link
+	DEVICE_MODEL := DNS-313 1-Bay Network Storage Enclosure
 	DEVICE_DTS := gemini-dlink-dns-313
 	DEVICE_TYPE := nas
 	DEVICE_PACKAGES := $(GEMINI_NAS_PACKAGES)
@@ -173,7 +175,8 @@ endef
 
 define Device/itian_sq201
 	$(Device/storlink-reference)
-	DEVICE_TITLE := ITian Square One SQ201
+	DEVICE_VENDOR := ITian
+	DEVICE_MODEL := Square One SQ201
 	DEVICE_DTS := gemini-sq201
 	DEVICE_PACKAGES += kmod-rt61-pci kmod-usb2-pci
 endef
@@ -181,7 +184,8 @@ TARGET_DEVICES += itian_sq201
 
 define Device/raidsonic_ib-4220-b
 	$(Device/storlink-reference)
-	DEVICE_TITLE := Raidsonic NAS IB-4220-B
+	DEVICE_VENDOR := Raidsonic
+	DEVICE_MODEL := NAS IB-4220-B
 	DEVICE_DTS := gemini-nas4220b
 	DEVICE_TYPE := nas
 endef
@@ -189,7 +193,8 @@ TARGET_DEVICES += raidsonic_ib-4220-b
 
 define Device/storlink_sl93512r
 	$(Device/storlink-reference)
-	DEVICE_TITLE := StorLink SL93512r
+	DEVICE_VENDOR := StorLink
+	DEVICE_MODEL := SL93512r
 	DEVICE_DTS := gemini-sl93512r
 endef
 TARGET_DEVICES += storlink_sl93512r
@@ -204,7 +209,8 @@ TARGET_DEVICES += storlink_sl93512r
 # and rootfs. It is expected that the OEM firmware adjusts the on flash
 # partition table with the values defined in the image header.
 define Device/wiliboard_wbd111
-	DEVICE_TITLE := Wiliboard WBD-111
+	DEVICE_VENDOR := Wiliboard
+	DEVICE_MODEL := WBD-111
 	DEVICE_DTS := gemini-wbd111
 	KERNEL := kernel-bin | append-dtb | wbd-nops
 	IMAGES := factory.bin
@@ -212,7 +218,8 @@ define Device/wiliboard_wbd111
 endef
 
 define Device/wiliboard_wbd222
-	DEVICE_TITLE := Wiliboard WBD-222
+	DEVICE_VENDOR := Wiliboard
+	DEVICE_MODEL := WBD-222
 	DEVICE_DTS := gemini-wbd222
 	KERNEL := kernel-bin | append-dtb | wbd-nops
 	IMAGES := factory.bin