From: Michael Pratt <mcpratt@pm.me>
Date: Fri, 14 Jun 2024 07:58:19 +0000 (-0400)
Subject: tools/coreutils: ignore gnulib changes to fcntl.h
X-Git-Url: http://git.cdn.openwrt.org/?a=commitdiff_plain;h=c24c3da00b2741b60a800891e1006fde3d9f76ae;p=openwrt%2Fstaging%2Fjow.git

tools/coreutils: ignore gnulib changes to fcntl.h

As a side-effect to adding a gnulib module for posix_fallocate(),
there are changes to the input file for fcntl.h which
are not handled here since autoreconf is not ran.

Skip updating the fcntl.h header from gnulib
and use the version shipped with the release.

Signed-off-by: Michael Pratt <mcpratt@pm.me>
Link: https://github.com/openwrt/openwrt/pull/15690
Signed-off-by: Robert Marko <robimarko@gmail.com>
---

diff --git a/tools/coreutils/Makefile b/tools/coreutils/Makefile
index f55fdcc1b2..5ef780d7d2 100644
--- a/tools/coreutils/Makefile
+++ b/tools/coreutils/Makefile
@@ -25,6 +25,7 @@ export GNULIB_SRCDIR:=$(HOST_GNULIB_SRCDIR)
 HOST_GNULIB_SKIP := \
 	lib/nstrftime.c \
 	lib/fprintftime.c \
+	lib/fcntl.in.h \
 	lib/locale.in.h
 
 HOST_CONFIGURE_ARGS += \