From: Felix Fietkau <nbd@openwrt.org>
Date: Sun, 12 Feb 2012 16:12:08 +0000 (+0000)
Subject: tools/genext2fs: do not include the host getline.h, it breaks the tool in subtle... 
X-Git-Url: http://git.cdn.openwrt.org/?a=commitdiff_plain;h=c2e411fa8df2b8a53a00882ec1888d872a32c0ae;p=openwrt%2Fstaging%2Fnbd.git

tools/genext2fs: do not include the host getline.h, it breaks the tool in subtle ways, and the source already has a getline replacement

SVN-Revision: 30479
---

diff --git a/tools/genext2fs/Makefile b/tools/genext2fs/Makefile
index 67fbef64e0..1f69b2a6b6 100644
--- a/tools/genext2fs/Makefile
+++ b/tools/genext2fs/Makefile
@@ -35,7 +35,7 @@ HOST_CONFIGURE_ARGS = \
 
 define Host/Compile
 	$(MAKE) -C $(HOST_BUILD_DIR) \
-		CFLAGS="$(HOST_CFLAGS) -include getline.h" \
+		CFLAGS="$(HOST_CFLAGS)" \
 		all
 endef