From: Daniel Dickinson <crazycshore@gmail.com>
Date: Mon, 4 Apr 2011 11:30:01 +0000 (+0000)
Subject: block-mount: Removed duplicated directory creation in the package install section... 
X-Git-Url: http://git.cdn.openwrt.org/?a=commitdiff_plain;h=c319b73399547a5531d3b6fb219855fdc619ec1c;p=openwrt%2Fstaging%2Faparcar.git

block-mount: Removed duplicated directory creation in the package install section. The duplicates were a result of the mergin the block-* packages.

SVN-Revision: 26469
---

diff --git a/package/block-mount/Makefile b/package/block-mount/Makefile
index ba19071b7b..1d4f7368cf 100644
--- a/package/block-mount/Makefile
+++ b/package/block-mount/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=block-mount
 PKG_VERSION:=0.2.0
-PKG_RELEASE:=2
+PKG_RELEASE:=3
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -50,7 +50,6 @@ define Package/block-mount/install
 	$(INSTALL_BIN) ./files/fstab.init $(1)/etc/init.d/fstab
 	$(INSTALL_DIR) $(1)/etc/config
 	$(INSTALL_DATA) ./files/fstab.config $(1)/etc/config/fstab
-	$(INSTALL_DIR) $(1)/lib/functions
 	$(INSTALL_DIR) $(1)/lib/functions/fsck
 	$(INSTALL_DATA) ./files/mount.sh $(1)/lib/functions/
 	$(INSTALL_DATA) ./files/fsck.sh $(1)/lib/functions/
@@ -59,13 +58,11 @@ define Package/block-mount/install
 	$(INSTALL_DATA) ./files/10-swap $(1)/etc/hotplug.d/block/
 	$(INSTALL_DATA) ./files/20-fsck $(1)/etc/hotplug.d/block/
 	$(INSTALL_DATA) ./files/40-mount $(1)/etc/hotplug.d/block/
-	$(INSTALL_DIR) $(1)/lib/functions
 	$(INSTALL_DATA) ./files/extmount.sh $(1)/lib/functions/
 	$(INSTALL_DIR) $(1)/lib/preinit
 	$(INSTALL_DATA) ./files/50_determine_usb_root $(1)/lib/preinit/
 	$(INSTALL_DATA) ./files/55_determine_extroot_sysupgrade $(1)/lib/preinit/
 	$(INSTALL_DATA) ./files/60_pivot_usb_root $(1)/lib/preinit/
-	$(INSTALL_DIR) $(1)/lib/preinit
 	echo "extroot_settle_time=\"$(CONFIG_EXTROOT_SETTLETIME)\"" >$(1)/lib/preinit/00_extroot.conf
 	$(INSTALL_DIR) $(1)/overlay
 endef