From: Rafał Miłecki <rafal@milecki.pl>
Date: Mon, 18 Jun 2018 06:42:56 +0000 (+0200)
Subject: bcm53xx: drop not ready support for Luxul devices
X-Git-Url: http://git.cdn.openwrt.org/?a=commitdiff_plain;h=c3d9109fadaf5f9c5b8fd095c7bfb637defbf9db;p=openwrt%2Fstaging%2Fansuel.git

bcm53xx: drop not ready support for Luxul devices

Support for these devices isn't ready yet and it was only accidentally
pushed in the commit 0da9303e5b44 ("mac80211: backport "brcmfmac:
cleanup and some rework" from 4.17").

Signed-off-by: Rafał Miłecki <rafal@milecki.pl>
---

diff --git a/target/linux/bcm53xx/image/Makefile b/target/linux/bcm53xx/image/Makefile
index 5cc5686cd0..596cb5ddb2 100644
--- a/target/linux/bcm53xx/image/Makefile
+++ b/target/linux/bcm53xx/image/Makefile
@@ -244,36 +244,6 @@ define Device/linksys-ea9500
 endef
 # TARGET_DEVICES += linksys-ea9500
 
-define Device/luxul-xap-1410
-  DEVICE_TITLE := Luxul XAP-1410
-  IMAGE/trx := append-rootfs | trx-serial
-endef
-TARGET_DEVICES += luxul-xap-1410
-
-define Device/luxul-xap-1510
-  DEVICE_TITLE := Luxul XAP-1510
-  IMAGE/trx := append-rootfs | trx-serial
-endef
-TARGET_DEVICES += luxul-xap-1510
-
-define Device/luxul-xwc-1000
-  DEVICE_TITLE := Luxul XWC-1000
-  IMAGE/trx := append-rootfs | trx-serial
-endef
-TARGET_DEVICES += luxul-xwc-1000
-
-define Device/luxul-xwr-1200
-  DEVICE_TITLE := Luxul XWR-1200
-  DEVICE_PACKAGES := $(USB2_PACKAGES)
-endef
-TARGET_DEVICES += luxul-xwr-1200
-
-define Device/luxul-xwr-3100
-  DEVICE_TITLE := Luxul XWR-3100
-  DEVICE_PACKAGES := $(IEEE8021X) kmod-brcmfmac $(USB3_PACKAGES)
-endef
-TARGET_DEVICES += luxul-xwr-3100
-
 define Device/netgear
   IMAGES := chk
   IMAGE/chk := append-ubi | trx-nand | netgear-chk