From: Steven Barth <cyrus@openwrt.org>
Date: Thu, 24 Apr 2014 09:11:44 +0000 (+0000)
Subject: 6rd: Select first IPv4 address from configured tunlink interface as local tunnel... 
X-Git-Url: http://git.cdn.openwrt.org/?a=commitdiff_plain;h=c4e09ccb052d27dd43a3ee76d4ff67d14563b68c;p=openwrt%2Fstaging%2Fynezz.git

6rd: Select first IPv4 address from configured tunlink interface as local tunnel address

Gives the user the control to select the correct WAN IPv4 address to be used by the 6rd tunnel when mutiple WAN interfaces are configured

Signed-off-by: Hans Dedecker <dedeckeh@gmail.com>

SVN-Revision: 40566
---

diff --git a/package/network/ipv6/6rd/Makefile b/package/network/ipv6/6rd/Makefile
index 19177f1c46..390e012c9f 100644
--- a/package/network/ipv6/6rd/Makefile
+++ b/package/network/ipv6/6rd/Makefile
@@ -8,7 +8,7 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=6rd
-PKG_VERSION:=6
+PKG_VERSION:=7
 PKG_RELEASE:=1
 
 include $(INCLUDE_DIR)/package.mk
diff --git a/package/network/ipv6/6rd/files/6rd.sh b/package/network/ipv6/6rd/files/6rd.sh
index 58b16c8ff7..db70b5a6c1 100644
--- a/package/network/ipv6/6rd/files/6rd.sh
+++ b/package/network/ipv6/6rd/files/6rd.sh
@@ -26,8 +26,13 @@ proto_6rd_setup() {
 	( proto_add_host_dependency "$cfg" 0.0.0.0 )
 
 	[ -z "$ipaddr" ] && {
-		local wanif
-		if ! network_find_wan wanif || ! network_get_ipaddr ipaddr "$wanif"; then
+		local wanif="$tunlink"
+		if [ -z $wanif ] && ! network_find_wan wanif; then
+			proto_notify_error "$cfg" "NO_WAN_LINK"
+			return
+		fi
+
+		if ! network_get_ipaddr ipaddr "$wanif"; then
 			proto_notify_error "$cfg" "NO_WAN_LINK"
 			return
 		fi