From: Adrian Schmutzler <freifunk@adrianschmutzler.de>
Date: Sat, 7 Dec 2019 22:37:40 +0000 (+0100)
Subject: ramips: remove unused DTS variable from DEVICE_VARS
X-Git-Url: http://git.cdn.openwrt.org/?a=commitdiff_plain;h=c4f6850efc4b76c82962c6db1f77dc63c5b1fd67;p=openwrt%2Fstaging%2Fdedeckeh.git

ramips: remove unused DTS variable from DEVICE_VARS

The DTS variable has been removed in 402138d12dca ("ramips: Derive
DTS name from device name in Makefile"), but the DEVICE_VARS entry
has been overlooked.

Remove it now since we are not using this variable.

This must _not_ be backported to 19.07, where the variable is still
in use.

Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
---

diff --git a/target/linux/ramips/image/Makefile b/target/linux/ramips/image/Makefile
index 16748b8260..d700e69440 100644
--- a/target/linux/ramips/image/Makefile
+++ b/target/linux/ramips/image/Makefile
@@ -7,7 +7,7 @@
 include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/image.mk
 
-DEVICE_VARS += DTS IMAGE_SIZE NETGEAR_BOARD_ID NETGEAR_HW_ID
+DEVICE_VARS += IMAGE_SIZE NETGEAR_BOARD_ID NETGEAR_HW_ID
 DEVICE_VARS += BUFFALO_TAG_PLATFORM BUFFALO_TAG_VERSION BUFFALO_TAG_MINOR
 DEVICE_VARS += SEAMA_SIGNATURE SEAMA_MTDBLOCK
 DEVICE_VARS += SERCOMM_HWID SERCOMM_HWVER SERCOMM_SWVER