From: Moritz Warning <moritzwarning@web.de>
Date: Mon, 9 Sep 2019 22:03:07 +0000 (+0200)
Subject: imx6: split up DEVICE_TITLE
X-Git-Url: http://git.cdn.openwrt.org/?a=commitdiff_plain;h=c546855188d148233f0b984564a2b4b9edd91d81;p=openwrt%2Fstaging%2Fblogic.git

imx6: split up DEVICE_TITLE

DEVICE_TITLE is split up into DEVICE_VENDOR, DEVICE_MODEL and DEVICE_VARIANT

Signed-off-by: Moritz Warning <moritzwarning@web.de>
---

diff --git a/target/linux/imx6/image/Makefile b/target/linux/imx6/image/Makefile
index 85d68230215d..b0933d77d20a 100644
--- a/target/linux/imx6/image/Makefile
+++ b/target/linux/imx6/image/Makefile
@@ -131,7 +131,9 @@ define Device/Default
 endef
 
 define Device/ventana
-  DEVICE_TITLE := Gateworks Ventana family (normal NAND flash)
+  DEVICE_VENDOR := Gateworks
+  DEVICE_MODEL := Ventana family
+  DEVICE_VARIANT := normal NAND flash
   DEVICE_DTS:= \
 	imx6dl-gw51xx \
 	imx6dl-gw52xx \
@@ -171,8 +173,10 @@ TARGET_DEVICES += ventana
 
 define Device/ventana-large
   $(Device/ventana)
+  DEVICE_VENDOR := Gateworks
+  DEVICE_MODEL := Ventana family
+  DEVICE_VARIANT := large NAND flash
   DEVICE_NAME := ventana
-  DEVICE_TITLE := Gateworks Ventana family (large NAND flash)
   IMAGES := nand.ubi
   PAGESIZE := 4096
   BLOCKSIZE := 256k
@@ -181,17 +185,19 @@ endef
 TARGET_DEVICES += ventana-large
 
 define Device/wandboard
-  DEVICE_TITLE := Wandboard Dual
+  DEVICE_VENDOR := Wandboard
+  DEVICE_MODEL := Dual
   DEVICE_DTS := imx6dl-wandboard
 endef
 TARGET_DEVICES += wandboard
 
 define Device/cubox-i
+  DEVICE_VENDOR := SolidRun
+  DEVICE_MODEL := CuBox-i
   KERNEL := kernel-bin | install-dtb
   UBOOT := mx6cuboxi
   BOOT_SCRIPT = bootscript-cubox
   DEVICE_NAME := cubox
-  DEVICE_TITLE := SolidRun CuBox-i
   DEVICE_PACKAGES := kmod-drm-imx kmod-drm-imx-hdmi kmod-usb-hid
   DEVICE_DTS := imx6q-cubox-i imx6dl-cubox-i imx6q-hummingboard imx6dl-hummingboard
   IMAGES := combined.bin
@@ -201,7 +207,8 @@ endef
 TARGET_DEVICES += cubox-i
 
 define Device/apalis
-  DEVICE_TITLE := Toradex Apalis family
+  DEVICE_VENDOR := Toradex
+  DEVICE_MODEL := Apalis family
   SUPPORTED_DEVICES := apalis,ixora apalis,eval
   DEVICE_DTS := \
 	  imx6q-apalis-eval \