From: Vasilis Tsiligiannis <acinonyx@openwrt.gr>
Date: Fri, 6 Apr 2012 12:05:59 +0000 (+0000)
Subject: Add git version check to prerequisite check (#11229)
X-Git-Tag: reboot~14330
X-Git-Url: http://git.cdn.openwrt.org/?a=commitdiff_plain;h=c56da13854769330651b790d9c9f933ca5ffebbd;p=openwrt%2Fopenwrt.git

Add git version check to prerequisite check (#11229)

SVN-Revision: 31214
---

diff --git a/include/prereq-build.mk b/include/prereq-build.mk
index c80e004c0c..2391e098c6 100644
--- a/include/prereq-build.mk
+++ b/include/prereq-build.mk
@@ -121,8 +121,12 @@ $(eval $(call RequireCommand,wget, \
 	Please install wget. \
 ))
 
-$(eval $(call RequireCommand,git, \
-	Please install git (git-core). \
+define Require/git
+	git --version | awk '($$$$1 == "git") && ($$$$2 == "version") && ($$$$3 >= "1.6.5") { print "ok" }' | grep ok > /dev/null
+endef
+
+$(eval $(call Require,git, \
+	Please install git (git-core) v1.6.5 or later. \
 ))
 
 define Require/gnutar