From: Felix Fietkau <nbd@openwrt.org>
Date: Sat, 31 Oct 2015 09:30:14 +0000 (+0000)
Subject: malta: set CPU_TYPE:=24kc.
X-Git-Url: http://git.cdn.openwrt.org/?a=commitdiff_plain;h=c5c2eb5fd6be8e9ec18b26189eb1dbd78d3ebb0a;p=openwrt%2Fstaging%2Fnbd.git

malta: set CPU_TYPE:=24kc.

There are instructions (e.g. wsbh) only available in MIPS32R2 which is
the isa level used by many MIPS targets in OpenWrt.  As we use the malta
target mostly for development and testing purposes, setting the CPU_TYPE
to 24Kc will make the emulation more real.

The following is output from qemu-system-mipsel 2.3.0

    root@OpenWrt:/# cat /proc/cpuinfo  | grep 'cpu model\|isa'
    cpu model               : MIPS 24Kc V0.0  FPU V0.0
    isa                     : mips1 mips2 mips32r1 mips32r2

Signed-off-by: Yousong Zhou <yszhou4tech@gmail.com>

SVN-Revision: 47324
---

diff --git a/target/linux/malta/Makefile b/target/linux/malta/Makefile
index 06cb68aee4..c9f1586aaa 100644
--- a/target/linux/malta/Makefile
+++ b/target/linux/malta/Makefile
@@ -8,6 +8,7 @@ include $(TOPDIR)/rules.mk
 
 BOARD:=malta
 BOARDNAME:=MIPS Malta CoreLV board (qemu)
+CPU_TYPE:=24kc
 SUBTARGETS:=le be #le64 be64
 INITRAMFS_EXTRA_FILES:=
 MAINTAINER:=Florian Fainelli <florian@openwrt.org>