From: Nicolas Thill <nico@openwrt.org>
Date: Fri, 23 Sep 2005 22:15:43 +0000 (+0000)
Subject: fix shfs-utils build
X-Git-Tag: whiterussian_rc4~175
X-Git-Url: http://git.cdn.openwrt.org/?a=commitdiff_plain;h=c6137e543b49251bc47e8e7b4b48b2c95f0136df;p=openwrt%2Fsvn-archive%2Fopenwrt.git

fix shfs-utils build

SVN-Revision: 1985
---

diff --git a/openwrt/package/shfs/Config.in b/openwrt/package/shfs/Config.in
index a464a4137e..d9f052754b 100644
--- a/openwrt/package/shfs/Config.in
+++ b/openwrt/package/shfs/Config.in
@@ -5,10 +5,11 @@ config BR2_PACKAGE_SHFS
 
 
 config BR2_PACKAGE_SHFS_UTILS
-	select BR2_PACKAGE_KMOD_SHFS
 	prompt "shfs-utils - ShFS mount/umount utilities"
 	tristate
 	default m if CONFIG_DEVEL
+	select BR2_PACKAGE_SHFS
+	select BR2_PACKAGE_KMOD_SHFS
 	help
 	  ShFS is a simple and easy to use Linux kernel module which 
 	  allows you to mount remote filesystems using a plain shell 
diff --git a/openwrt/package/shfs/Makefile b/openwrt/package/shfs/Makefile
index 653bc1c4fd..f87a63b418 100644
--- a/openwrt/package/shfs/Makefile
+++ b/openwrt/package/shfs/Makefile
@@ -28,10 +28,9 @@ $(PKG_BUILD_DIR)/.built:
 		OFLAGS="$(TARGET_CFLAGS)" \
 		CC="$(TARGET_CC)" \
 		LINKER="$(TARGET_CC)" \
-		KERNEL="$(LINUX_VERSION)" \
 		KERNEL_SOURCES="$(LINUX_DIR)" \
 		ROOT="$(PKG_INSTALL_DIR)" \
-		all install
+		utils utils-install
 	touch $@
 
 $(IPKG_SHFS_UTILS):