From: Felix Fietkau <nbd@openwrt.org>
Date: Wed, 17 Oct 2012 13:03:08 +0000 (+0000)
Subject: toolchain: enable parallel build for uClibc, remove the obsolete TOOLCHAIN_PARALLEL... 
X-Git-Tag: reboot~12591
X-Git-Url: http://git.cdn.openwrt.org/?a=commitdiff_plain;h=c6ba19c70e1bde7cb94c77ae64537294cfef2ae9;p=openwrt%2Fstaging%2Fxback.git

toolchain: enable parallel build for uClibc, remove the obsolete TOOLCHAIN_PARALLEL config symbol

SVN-Revision: 33807
---

diff --git a/Config.in b/Config.in
index c023d60793..cca5a4c0f0 100644
--- a/Config.in
+++ b/Config.in
@@ -495,20 +495,6 @@ menu "Global build settings"
 		  Only say Y, if you don't mind fixing broken packages.
 		  Before reporting build bugs, set this to N and re-run the build.
 
-	config TOOLCHAIN_PARALLEL
-		bool
-		prompt "Parallelize the toolchain build (May break build)"
-		depends on PKG_BUILD_PARALLEL
-		depends on BROKEN
-		default n
-		help
-		  Build the toolchain with parallel make jobs.
-		  This speeds up the toolchain build on SMP machines, but may
-		  break the build for certain toolchain versions.
-
-		  If you say Y, toolchain build might break.
-		  Before reporting build bugs, set this to N and re-run the build.
-
 	comment "Stripping options"
 
 	choice
diff --git a/include/toolchain-build.mk b/include/toolchain-build.mk
index d2fdb0281a..a86f6aba77 100644
--- a/include/toolchain-build.mk
+++ b/include/toolchain-build.mk
@@ -11,8 +11,6 @@ REAL_STAGING_DIR_HOST:=$(STAGING_DIR_HOST)
 STAGING_DIR_HOST:=$(TOOLCHAIN_DIR)
 BUILD_DIR_HOST:=$(BUILD_DIR_TOOLCHAIN)
 
-TOOLCHAIN_JOBS?=$(if $(CONFIG_TOOLCHAIN_PARALLEL),-j$(CONFIG_PKG_BUILD_JOBS))
-
 include $(INCLUDE_DIR)/host-build.mk
 
 HOST_STAMP_PREPARED=$(HOST_BUILD_DIR)/.prepared
diff --git a/toolchain/uClibc/Makefile b/toolchain/uClibc/Makefile
index 0c2dcd3837..545ea5ae56 100644
--- a/toolchain/uClibc/Makefile
+++ b/toolchain/uClibc/Makefile
@@ -5,6 +5,8 @@ include ./common.mk
 HOST_STAMP_BUILT:=$(HOST_BUILD_DIR)/.built
 HOST_STAMP_INSTALLED:=$(TOOLCHAIN_DIR)/stamp/.uclibc_installed
 
+HOST_BUILD_PARALLEL:=1
+
 define Host/SetToolchainInfo
 	$(SED) 's,^\(LIBC_TYPE\)=.*,\1=$(PKG_NAME),' $(TOOLCHAIN_DIR)/info.mk
 	$(SED) 's,^\(LIBC_URL\)=.*,\1=http://www.uclibc.org/,' $(TOOLCHAIN_DIR)/info.mk
diff --git a/toolchain/uClibc/common.mk b/toolchain/uClibc/common.mk
index 5f3bd29444..f32ed98729 100644
--- a/toolchain/uClibc/common.mk
+++ b/toolchain/uClibc/common.mk
@@ -50,7 +50,7 @@ CPU_CFLAGS = \
 	-Wno-unused-but-set-variable \
 	$(TARGET_CFLAGS)
 
-UCLIBC_MAKE = PATH='$(TOOLCHAIN_DIR)/initial/bin:$(TARGET_PATH)' $(MAKE) -C $(HOST_BUILD_DIR) \
+UCLIBC_MAKE = PATH='$(TOOLCHAIN_DIR)/initial/bin:$(TARGET_PATH)' $(MAKE) $(HOST_JOBS) -C $(HOST_BUILD_DIR) \
 	$(TARGET_CONFIGURE_OPTS) \
 	DEVEL_PREFIX=/ \
 	RUNTIME_PREFIX=/ \